summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2016-03-01 20:35:34 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2016-03-01 20:35:54 +0100
commitfe3faddb9bf793b16a104bc5f0d304f14e8cf057 (patch)
tree8e699eefa58b2cd8cabe90a0ba4ab103106d83a7
parentx11-misc/arandr: Fix description. Clean up ebuild. (diff)
downloadgentoo-fe3faddb.tar.gz
gentoo-fe3faddb.tar.bz2
gentoo-fe3faddb.zip
dev-python/cryptography: work with openssl 1.0.2g
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--dev-python/cryptography/cryptography-1.2.2.ebuild2
-rw-r--r--dev-python/cryptography/files/cryptography-1.2.2-openssl-1.0.2g-mem_buf.patch12
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/cryptography/cryptography-1.2.2.ebuild b/dev-python/cryptography/cryptography-1.2.2.ebuild
index ae9dbd1f7e97..af7e5a19a275 100644
--- a/dev-python/cryptography/cryptography-1.2.2.ebuild
+++ b/dev-python/cryptography/cryptography-1.2.2.ebuild
@@ -43,6 +43,8 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+PATCHES=( "${FILESDIR}/${PN}-1.2.2-openssl-1.0.2g-mem_buf.patch" )
+
python_test() {
py.test -v -v -x || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/cryptography/files/cryptography-1.2.2-openssl-1.0.2g-mem_buf.patch b/dev-python/cryptography/files/cryptography-1.2.2-openssl-1.0.2g-mem_buf.patch
new file mode 100644
index 000000000000..64d270b6e963
--- /dev/null
+++ b/dev-python/cryptography/files/cryptography-1.2.2-openssl-1.0.2g-mem_buf.patch
@@ -0,0 +1,12 @@
+diff -ru cryptography-1.2.2/src/_cffi_src/openssl/bio.py cryptography-1.2.2-fixed/src/_cffi_src/openssl/bio.py
+--- cryptography-1.2.2/src/_cffi_src/openssl/bio.py 2016-01-29 20:26:11.000000000 +0100
++++ cryptography-1.2.2-fixed/src/_cffi_src/openssl/bio.py 2016-03-01 20:32:25.172776288 +0100
+@@ -99,7 +99,7 @@
+ BIO *BIO_next(BIO *);
+ BIO *BIO_find_type(BIO *, int);
+ BIO_METHOD *BIO_s_mem(void);
+-BIO *BIO_new_mem_buf(void *, int);
++BIO *BIO_new_mem_buf(const void *, int);
+ BIO_METHOD *BIO_s_file(void);
+ BIO *BIO_new_file(const char *, const char *);
+ BIO *BIO_new_fp(FILE *, int);