summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:45:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:55:56 +0200
commitfe61fcc40d50ff7c82641e69ba5baefbddea1933 (patch)
tree2b3d84daa66221bb822c4a946b28117615b2a21f
parentdev-python/terminado: Remove redundant versions (diff)
downloadgentoo-fe61fcc40d50ff7c82641e69ba5baefbddea1933.tar.gz
gentoo-fe61fcc40d50ff7c82641e69ba5baefbddea1933.tar.bz2
gentoo-fe61fcc40d50ff7c82641e69ba5baefbddea1933.zip
dev-python/testfixtures: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/testfixtures/Manifest2
-rw-r--r--dev-python/testfixtures/testfixtures-4.9.1.ebuild56
-rw-r--r--dev-python/testfixtures/testfixtures-6.8.2.ebuild55
3 files changed, 0 insertions, 113 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 89f856d155a7..ed2d29ac656c 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1,3 +1 @@
-DIST testfixtures-4.9.1.tar.gz 90117 BLAKE2B 6560d4072f8b0108b7d7708c980f40df1a05af88df86dd01926bdf0eab107744fc89d75bdedaced7300c24a52a9d1c0685f5dd3f5f732121ff97af6d0859055a SHA512 20053d22297b7852382a4f2bf6d76bde6489f788a9073aaae407f68bb6b3d7bdc4a045868cf7c99fd294936768745ee7d652c86a4a96c33fb0e95fa0d96d2a59
DIST testfixtures-6.14.1.tar.gz 114969 BLAKE2B 21e6b377e24240cb275feed2e160da256ca75884c5a6dc842364986031c3cd21fb1b5bc13f3e8780354d47179e6c038cb461a39a04d34bfc8beebbf9809d6431 SHA512 0da31d5e382984c22ada846c07570d4a179ba819005dd29891e551b99190fabaaf17174456f7ed4864e9c4aa25f7d5d8b86aa123b4628328610d6930c9c5d6bd
-DIST testfixtures-6.8.2.tar.gz 110838 BLAKE2B 4b83a1459aec4bc4b4dcdff48603958bfd115806ce0c567faad37ac273e93096cf964af08d24b98c1743d6302d1b2f6f9c9498023c781ab3e9170e2eda74cefe SHA512 ce6561d976a0b8f79ae72aaca6f5ffa8d1cae30ad73d3d88625ed4fe55da5f0a913785fa3e9aeb4268dfb243a7b74dddc262554521a71c766089383aa5b0e022
diff --git a/dev-python/testfixtures/testfixtures-4.9.1.ebuild b/dev-python/testfixtures/testfixtures-4.9.1.ebuild
deleted file mode 100644
index 60bd10d75f5f..000000000000
--- a/dev-python/testfixtures/testfixtures-4.9.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/manuel[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose-cover3[${PYTHON_USEDEP}]
- dev-python/nose_fixes[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Makefile comes set pointing at a wrong location
- sed \
- -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' \
- -i docs/Makefile || die
- # Prevent un-needed download during build, fix Makefile for doc build
- sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
-
- # remove test that tests the stripped zope-component test_components.ComponentsTests
- rm -f testfixtures/tests/test_components.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests --verbosity=3 || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/testfixtures/testfixtures-6.8.2.ebuild b/dev-python/testfixtures/testfixtures-6.8.2.ebuild
deleted file mode 100644
index 1acbddb94ceb..000000000000
--- a/dev-python/testfixtures/testfixtures-6.8.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
-HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-django[${PYTHON_USEDEP}]
- dev-python/sybil[${PYTHON_USEDEP}]
- >=dev-python/twisted-18[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Prevent un-needed download during build, fix Makefile for doc build
- sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
-
- # remove test that tests the stripped zope-component test_components.ComponentsTests
- rm -f testfixtures/tests/test_components.py docs/components.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="." \
- DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings \
- pytest -vv || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}