summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-20 19:53:10 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-20 20:01:31 +0200
commitfe754f0c7a625eb01996dd71e303fa1b4b843134 (patch)
tree712d14df1c6ce6a900c3069bbc78ba78ec580cd7
parentdev-python/secretstorage: enable py3.11 (diff)
downloadgentoo-fe754f0c.tar.gz
gentoo-fe754f0c.tar.bz2
gentoo-fe754f0c.zip
dev-python/pyxdg: update EAPI 7 -> 8, py3.11, PEP517, nose -> pytest
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/pyxdg/pyxdg-0.27-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.27-r1.ebuild b/dev-python/pyxdg/pyxdg-0.27-r1.ebuild
new file mode 100644
index 000000000000..4361e4055cf8
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.27-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-rel-${PV}"
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # epytest does not work here for some reason:
+ # No such file or directory: '-vv'
+ #
+ # Can't import xdg unless already installed,
+ # workaround with PYTHONPATH
+ PYTHONPATH="${S}" pytest test/* -vv || die "Tests failed with ${EPYTHON}"
+}