summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-03-11 11:05:11 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-03-11 11:05:43 -0400
commitfe805b1149dbd2460a908b410046244d384d3f72 (patch)
tree9cc2c92bebb275b3da8df36918202205e203f808
parentnet-wireless/bluez: Version bump to 5.53 (diff)
downloadgentoo-fe805b11.tar.gz
gentoo-fe805b11.tar.bz2
gentoo-fe805b11.zip
www-servers/varnish: version bump to 6.3.2
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/varnish-6.3.2.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 8ba57c9585c2..52cab9fa30a9 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -7,3 +7,4 @@ DIST varnish-6.1.1.tgz 3135623 BLAKE2B c39904fe2745ab601e7c1f6d85850fe1a83c19e8d
DIST varnish-6.2.2.tgz 3208447 BLAKE2B 051efacf5b956a0f83723e4a0dd69291fa2215378e2c8b7ca653a87f7b10871b323ed0ee9bc1ed4d1602526b882c2a94b981f3b194584c463d6a7fba18055845 SHA512 cc03fd1833b86e74ca275797da5e16b8ce754c7a9d232d5825c876eacc632d7e4edfae0a15e49b36cb551aea1e72a0d054da06433321498a3c74789c545f6c7a
DIST varnish-6.3.0.tgz 3308117 BLAKE2B ee9a1ab87ceb96fbfeaa4130da6043f2474cfc6a29ab9f8d74cc66e28003467b63916f7fe498be4cd63fe80ac347bf02e2a5434afab381da32bcb821c9bb5404 SHA512 887c27b498bdac1ddb01759569078e2394a0a754ab3842f866fd06724f154950accebe80c5412b0ba5dd70ff9f687ce4bad3161d1bd32448e0d50aa01c6f96b1
DIST varnish-6.3.1.tgz 3306392 BLAKE2B d34e52567fc0a9c57ac894c79155b43279a7b1549651494053f3eca3ddf83d234e41cffa4fed4833535b3c07e2a62ec0f54a1cc69c1bd689fee4ab90252f6588 SHA512 2fee11bcd01f53464b53e8271c2aec08233af078f2e9a2600cd82efbf646b3fd48160ebb2add09e1fb4f43e18e61f21a2408e351eeb2a567179733a3efbc3ddc
+DIST varnish-6.3.2.tgz 3323908 BLAKE2B 5bde1b2ececeb8aed884db22ed75bfd74f82d68416e71400a4c0d27483fcceb029fe8e724e30754899c872d7028da5cb759545f0743a11d0e90b0fd604af0ad7 SHA512 0f476c642df834737d446b3bc6ac8afa5981d1de5810dc6e8556eb22b2ca26d64eb531f4ad3332eb86e231a7443fe35393177ec6dbee97a837f405d1aa9d03cd
diff --git a/www-servers/varnish/varnish-6.3.2.ebuild b/www-servers/varnish/varnish-6.3.2.ebuild
new file mode 100644
index 000000000000..87e7399056bc
--- /dev/null
+++ b/www-servers/varnish/varnish-6.3.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable jit pcre-jit ) \
+ $(use_with jemalloc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins lib/libvmod_std/vmod.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+}