summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-26 06:23:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-26 06:42:10 +0200
commitfea1d1b69ebee2a5afc4dbd8e143eeff40728a4f (patch)
treeabc2f2bbc18f110ecd38fcbceac38dff2dcb0826
parentdev-python/pylint: Bump to 2.17.6 (diff)
downloadgentoo-fea1d1b69ebee2a5afc4dbd8e143eeff40728a4f.tar.gz
gentoo-fea1d1b69ebee2a5afc4dbd8e143eeff40728a4f.tar.bz2
gentoo-fea1d1b69ebee2a5afc4dbd8e143eeff40728a4f.zip
dev-python/pydyf: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pydyf/Manifest1
-rw-r--r--dev-python/pydyf/pydyf-0.8.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pydyf/Manifest b/dev-python/pydyf/Manifest
index 74dd6d3af7f7..476f0e042f10 100644
--- a/dev-python/pydyf/Manifest
+++ b/dev-python/pydyf/Manifest
@@ -1 +1,2 @@
DIST pydyf-0.7.0.tar.gz 16186 BLAKE2B 8dec96ba9d263ed503f1b13c8cfc6eafbd66c7d1cc080b5a18476c93063c0099c46c3362bbeeb71a796fbfdadbd2007c9858b21053464adc243a7d1f7a2f9a54 SHA512 cfc58170b57684cbf5233ca48798881a980af0b3e3fdc8da91c5932affee0365f1e9d535df1f983e0f16c6e612ec5048c91d236bf69b6fae46c7e59f6c2388d0
+DIST pydyf-0.8.0.tar.gz 16342 BLAKE2B c2c00d63fc4fb2aabed20f39fc08fb2b2628e7a9d31d7504d8461331e0ba4654f26e129eb3d9ccf1ab4f376f7ace4f15d6bf87fd74b76c2d50a2a741f7fadb14 SHA512 c78913e723593a4e76c36b7a9b3ddd8a85af856a967053d8f7f297901deb2c6a723e98b3ef311e1c9618018e0e727a2d8eaff1adedb52c743facb85491e8d102
diff --git a/dev-python/pydyf/pydyf-0.8.0.ebuild b/dev-python/pydyf/pydyf-0.8.0.ebuild
new file mode 100644
index 000000000000..f905c99e37d8
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest