summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2017-11-16 19:03:54 +0000
committerDenis Dupeyron <calchan@gentoo.org>2017-11-16 19:05:45 +0000
commitfeb4dc7d109f21da58604cb24640a3f8e39b15ab (patch)
tree17d3c3093dd85ea9708f0e3c2397bce42752e2b5
parentprofiles: Initiate last-rites for Qt4WebKit and remaining rdeps (diff)
downloadgentoo-feb4dc7d109f21da58604cb24640a3f8e39b15ab.tar.gz
gentoo-feb4dc7d109f21da58604cb24640a3f8e39b15ab.tar.bz2
gentoo-feb4dc7d109f21da58604cb24640a3f8e39b15ab.zip
xfce-base/thunar: fix CVE-2013-7447 (integer overflow), bug #574382
Package-Manager: Portage-2.3.14, Repoman-2.3.6
-rw-r--r--xfce-base/thunar/files/thunar-1.16.2-integer-overflow.patch29
-rw-r--r--xfce-base/thunar/thunar-1.6.12-r1.ebuild (renamed from xfce-base/thunar/thunar-1.6.12.ebuild)3
2 files changed, 32 insertions, 0 deletions
diff --git a/xfce-base/thunar/files/thunar-1.16.2-integer-overflow.patch b/xfce-base/thunar/files/thunar-1.16.2-integer-overflow.patch
new file mode 100644
index 000000000000..09f4b9374435
--- /dev/null
+++ b/xfce-base/thunar/files/thunar-1.16.2-integer-overflow.patch
@@ -0,0 +1,29 @@
+From 1736b1f69ecf3e44a1b957d8090fb04c6bc5fd95 Mon Sep 17 00:00:00 2001
+From: Mikhail Efremov <sem@altlinux.org>
+Date: Thu, 11 Feb 2016 18:59:27 +0300
+Subject: [PATCH] Fix potential buffer overflow
+
+Use g_malloc_n() instead of g_malloc to avoid integer overflow.
+This fixes CVE-2013-7447, see
+http://www.openwall.com/lists/oss-security/2016/02/10/2
+for details.
+---
+ thunar/thunar-gdk-extensions.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/thunar/thunar-gdk-extensions.c b/thunar/thunar-gdk-extensions.c
+index 50ecb4a..775eca3 100644
+--- a/thunar/thunar-gdk-extensions.c
++++ b/thunar/thunar-gdk-extensions.c
+@@ -75,7 +75,7 @@ thunar_gdk_cairo_create_surface (const GdkPixbuf *pixbuf)
+
+ /* prepare pixel data and surface */
+ cairo_stride = cairo_format_stride_for_width (format, width);
+- cairo_pixels = g_malloc (height * cairo_stride);
++ cairo_pixels = g_malloc_n (height, cairo_stride);
+ surface = cairo_image_surface_create_for_data (cairo_pixels, format,
+ width, height, cairo_stride);
+ cairo_surface_set_user_data (surface, &cairo_key, cairo_pixels, g_free);
+--
+2.6.5
+
diff --git a/xfce-base/thunar/thunar-1.6.12.ebuild b/xfce-base/thunar/thunar-1.6.12-r1.ebuild
index c34167b9a8a3..f1baaf54ef0d 100644
--- a/xfce-base/thunar/thunar-1.6.12.ebuild
+++ b/xfce-base/thunar/thunar-1.6.12-r1.ebuild
@@ -48,6 +48,9 @@ REQUIRED_USE="trash-panel-plugin? ( dbus )"
S=${WORKDIR}/${MY_P}
DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+PATCHES=(
+ "${FILESDIR}"/thunar-1.16.2-integer-overflow.patch
+)
src_configure() {
local myconf=(