summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 00:07:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 00:30:19 +0100
commitfeb73daa200c85da922eb8fbbcc28c303ca9f595 (patch)
tree87815a9009c4e103ac4e788ab93aa1fc9de63009
parentdev-python/nuitka: Bump to 0.7.1 (diff)
downloadgentoo-feb73daa.tar.gz
gentoo-feb73daa.tar.bz2
gentoo-feb73daa.zip
dev-python/testfixtures: Bump to 6.18.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-6.18.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 6925357657c3..67558de479e1 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -1 +1,2 @@
DIST testfixtures-6.18.3.tar.gz 122142 BLAKE2B 014cc2245d5fbe0d39310c8e2c21cd5f289d6ec7a6a561d055e86d4cd25b79f1aa535067746219e2382df2aeec050dfa24cdae674636d92ee61016fa9861e705 SHA512 e556e7cb28f122526ef19550b1e593b61f01923d0be53951344f917f89b3d4cae29e525ceda3d0290bc18c3641b509dd7236e7b55ae50da0157fe11ca9f04cca
+DIST testfixtures-6.18.4.tar.gz 124910 BLAKE2B 8c19672903d3b6ba5139b95f1d060c0d71ae8891e8c190a8891fded6d79af3549a91809b73a114f69cf2b0de49740e49a9e38e44981addcd09d7b4c343ea3ced SHA512 2643ddfd7c4be7b514070e2df8e52479ad51f50a8b69507faf36d90bd92aa0201f1c3033eb00e644bac194601b0a9190c02727f18d899629ab09abfa3546ecd7
diff --git a/dev-python/testfixtures/testfixtures-6.18.4.ebuild b/dev-python/testfixtures/testfixtures-6.18.4.ebuild
new file mode 100644
index 000000000000..8755772cbbc7
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-6.18.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/sybil[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # kill weird way of declaring build deps
+ sed -e '/build=/d' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTHONPATH="."
+ local -x DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_missing
+ testfixtures/tests/test_shouldwarn.py::ShouldWarnTests::test_filter_present
+ )
+
+ epytest
+}