summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-28 06:57:10 +0100
committerSam James <sam@gentoo.org>2024-04-28 07:50:29 +0100
commitfec2c6a98da2059f5d696d0015c0c75cd522dd7d (patch)
tree068e50f481a67c858729e001fa6e163fadf2be94
parentapp-admin/gopass: Keyword 1.15.13 arm64, #930430 (diff)
downloadgentoo-fec2c6a98da2059f5d696d0015c0c75cd522dd7d.tar.gz
gentoo-fec2c6a98da2059f5d696d0015c0c75cd522dd7d.tar.bz2
gentoo-fec2c6a98da2059f5d696d0015c0c75cd522dd7d.zip
dev-perl/Alien-Gnuplot: add 1.43.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-perl/Alien-Gnuplot/Alien-Gnuplot-1.43.0.ebuild32
-rw-r--r--dev-perl/Alien-Gnuplot/Manifest1
-rw-r--r--dev-perl/Alien-Gnuplot/files/Alien-Gnuplot-1.43.0-version.patch13
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Alien-Gnuplot/Alien-Gnuplot-1.43.0.ebuild b/dev-perl/Alien-Gnuplot/Alien-Gnuplot-1.43.0.ebuild
new file mode 100644
index 000000000000..6c6743be004c
--- /dev/null
+++ b/dev-perl/Alien-Gnuplot/Alien-Gnuplot-1.43.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_VERSION=1.043
+DIST_AUTHOR=ETJ
+inherit perl-module
+
+DESCRIPTION="Find and verify functionality of the gnuplot executable"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-perl/Alien-Build-0.250.0
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-HTTP-Tiny
+ virtual/perl-Time-HiRes
+ sci-visualization/gnuplot
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Alien-Build-2.190.0
+ >=dev-perl/Alien-Base-ModuleBuild-0.320.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+ dev-perl/File-Which
+ test? ( dev-perl/Test-Exception )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.43.0-version.patch" )
diff --git a/dev-perl/Alien-Gnuplot/Manifest b/dev-perl/Alien-Gnuplot/Manifest
index 1dafcdaf3695..a326e3dc43dc 100644
--- a/dev-perl/Alien-Gnuplot/Manifest
+++ b/dev-perl/Alien-Gnuplot/Manifest
@@ -1 +1,2 @@
DIST Alien-Gnuplot-1.034.tar.gz 8662 BLAKE2B ce0f520326c2228f68c826a49c1793a7e7152e22a7593ae2e99094c8db1348f8e566efbc963b0089965681a5586b71fd8551b0a230b81506e2229ab538861fe0 SHA512 9fc4d9e92a478c9399802b5161966efc625b676afaef2f212e8706da28a03f4fc265df953e55f0ad541795d90aa9066f71838362146cb8aae3caf9f0ea157fc8
+DIST Alien-Gnuplot-1.043.tar.gz 9861 BLAKE2B b535c046fed769806050d89002de7eec72d41d9ef7c01095c7d4c94760a130ad69cb966d2eebe4fc9e9e8181007eb1004a9385cfe0c8b64cdd9d0bee9ed09cc6 SHA512 18ac5b36cb5b6bfc514a7050caa5663bead2e0597c9078fb71e90ab601a8d7f4eb0cbbe8dd6e007f0248aa826cc15d7938e61c8a02eb01f6a230f009c80ca45e
diff --git a/dev-perl/Alien-Gnuplot/files/Alien-Gnuplot-1.43.0-version.patch b/dev-perl/Alien-Gnuplot/files/Alien-Gnuplot-1.43.0-version.patch
new file mode 100644
index 000000000000..7b49ae5016e2
--- /dev/null
+++ b/dev-perl/Alien-Gnuplot/files/Alien-Gnuplot-1.43.0-version.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/709670
+
+--- a/lib/Alien/Gnuplot.pm
++++ b/lib/Alien/Gnuplot.pm
+@@ -316,7 +316,7 @@ Raw output from Gnuplot:
+ $lines
+ };
+
+- $lines =~ m/Version (\d+\.\d+) (patchlevel (\d+))?/ or die qq{
++ $lines =~ m/Version (\d+\.\d+(?:\.\d+)?) (patchlevel (\d+))?/ or die qq{
+ Alien::Gnuplot: the executable file $exec_path claims to be gnuplot, but
+ I could not parse a version number from its output. Sorry, I give up.
+