summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-29 17:41:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-01 16:26:02 +0200
commitfec52e6f9767385205ce4037fbb88597f5ad73f7 (patch)
tree845cf9afebaa647ce236b509d11d39e3b2f21d02
parentmedia-sound/beets: Fix minimum dev-python/jellyfish dep (diff)
downloadgentoo-fec52e6f.tar.gz
gentoo-fec52e6f.tar.bz2
gentoo-fec52e6f.zip
media-gfx/krita: 4.2.0 version bump
dev-qt/qtgui slot operator is necessary for QPA usage. Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/krita/Manifest1
-rw-r--r--media-gfx/krita/files/krita-4.2.0-tests-optional.patch324
-rw-r--r--media-gfx/krita/krita-4.2.0.ebuild118
3 files changed, 443 insertions, 0 deletions
diff --git a/media-gfx/krita/Manifest b/media-gfx/krita/Manifest
index 471a7accb4d3..00caf204e911 100644
--- a/media-gfx/krita/Manifest
+++ b/media-gfx/krita/Manifest
@@ -1 +1,2 @@
DIST krita-4.1.8.tar.gz 244065767 BLAKE2B ba2cbb6d1575cec189e8f10461b720a081f185e1e078fc1e8194c9e6d455dade45f35f1ae5a891717918b3c03863a2a7f3f819753a106ede5695003cfa260157 SHA512 d027444415bffbd6abd29ca69598fdb1e6a652fd4f1944092ff12016a57ff2ee3bab209c93e065905ec9bfea395e50f833915bb924b97a2c119d101057cba6c9
+DIST krita-4.2.0.tar.gz 240015177 BLAKE2B 09992b50dfa4e244c809dd576c3b7c0d1cb09b19fde0985c3d72b57543e5a06aa863b9011d655432a089fb6869e2e7fdb23939877b0c4ee6aaf44a1c88e7084c SHA512 a6f373839e47c4e97f5680d266d1ea9f438db6636d3f8749f7fbf6d93b5329e1d46f7233af901dd224722c08100c4fc3b162a163c721299ebfa2d4939032ae44
diff --git a/media-gfx/krita/files/krita-4.2.0-tests-optional.patch b/media-gfx/krita/files/krita-4.2.0-tests-optional.patch
new file mode 100644
index 000000000000..b605e922aba1
--- /dev/null
+++ b/media-gfx/krita/files/krita-4.2.0-tests-optional.patch
@@ -0,0 +1,324 @@
+--- a/plugins/color/lcms2engine/CMakeLists.txt 2019-06-01 15:10:43.442258240 +0200
++++ b/plugins/color/lcms2engine/CMakeLists.txt 2019-06-01 15:10:43.452257980 +0200
+@@ -1,6 +1,8 @@
+ project( lcmsengine )
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${LCMS2_INCLUDE_DIR}
+--- a/plugins/extensions/qmic/CMakeLists.txt 2019-06-01 15:10:43.469257540 +0200
++++ b/plugins/extensions/qmic/CMakeLists.txt 2019-06-01 15:10:43.477257332 +0200
+@@ -20,4 +20,6 @@
+ target_link_libraries(kritaqmic kritaui)
+ install(TARGETS kritaqmic DESTINATION ${KRITA_PLUGIN_INSTALL_DIR})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/filters/CMakeLists.txt 2019-06-01 15:10:43.488257047 +0200
++++ b/plugins/filters/CMakeLists.txt 2019-06-01 15:10:43.497256813 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+ add_subdirectory( blur )
+ add_subdirectory( colors )
+ add_subdirectory( colorsfilters )
+--- a/plugins/filters/unsharp/CMakeLists.txt 2019-06-01 15:10:43.508256528 +0200
++++ b/plugins/filters/unsharp/CMakeLists.txt 2019-06-01 15:10:43.516256320 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaunsharpfilter_SOURCES
+ unsharp.cpp
+--- a/plugins/dockers/lut/CMakeLists.txt 2019-06-01 15:10:43.527256035 +0200
++++ b/plugins/dockers/lut/CMakeLists.txt 2019-06-01 15:10:43.535255828 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM
+ ${OCIO_INCLUDE_DIR}
+--- a/plugins/dockers/animation/CMakeLists.txt 2019-06-01 15:10:43.546255542 +0200
++++ b/plugins/dockers/animation/CMakeLists.txt 2019-06-01 15:10:43.555255309 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif()
+
+ set(KRITA_ANIMATIONDOCKER_SOURCES
+--- a/plugins/tools/tool_transform2/CMakeLists.txt 2019-06-01 15:10:43.566255024 +0200
++++ b/plugins/tools/tool_transform2/CMakeLists.txt 2019-06-01 15:10:43.574254816 +0200
+@@ -1,5 +1,7 @@
+ if (NOT WIN32 AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif()
+
+ set(kritatooltransform_SOURCES
+--- a/plugins/tools/basictools/CMakeLists.txt 2019-06-01 15:10:43.584254557 +0200
++++ b/plugins/tools/basictools/CMakeLists.txt 2019-06-01 15:10:43.592254349 +0200
+@@ -1,5 +1,7 @@
+ if (NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif ()
+
+ set(kritadefaulttools_SOURCES
+--- a/plugins/impex/tiff/CMakeLists.txt 2019-06-01 15:10:43.602254090 +0200
++++ b/plugins/impex/tiff/CMakeLists.txt 2019-06-01 15:10:43.609253908 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(libkritatiffconverter_LIB_SRCS
+ kis_tiff_converter.cc
+--- a/plugins/impex/libkra/CMakeLists.txt 2019-06-01 15:10:43.620253623 +0200
++++ b/plugins/impex/libkra/CMakeLists.txt 2019-06-01 15:10:43.627253441 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritalibkra_LIB_SRCS
+ kis_colorize_dom_utils.cpp
+--- a/plugins/impex/jpeg/CMakeLists.txt 2019-06-01 15:10:43.638253156 +0200
++++ b/plugins/impex/jpeg/CMakeLists.txt 2019-06-01 15:10:43.646252949 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(ICCJPEG_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/lcms")
+
+--- a/plugins/impex/psd/CMakeLists.txt 2019-06-01 15:10:43.662252534 +0200
++++ b/plugins/impex/psd/CMakeLists.txt 2019-06-01 15:10:43.671252300 +0200
+@@ -1,5 +1,7 @@
+ if (NOT MSVC AND NOT APPLE)
+- add_subdirectory(tests)
++ if(BUILD_TESTING)
++add_subdirectory(tests)
++endif()
+ endif()
+
+ configure_file(config_psd.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config_psd.h)
+--- a/plugins/impex/xcf/CMakeLists.txt 2019-06-01 15:10:43.685251937 +0200
++++ b/plugins/impex/xcf/CMakeLists.txt 2019-06-01 15:10:43.694251704 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(XCFTOOLS_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/xcftools")
+
+--- a/plugins/impex/heightmap/CMakeLists.txt 2019-06-01 15:10:43.705251418 +0200
++++ b/plugins/impex/heightmap/CMakeLists.txt 2019-06-01 15:10:43.714251185 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories( ${CMAKE_CURRENT_SOURCE_DIR} )
+
+--- a/plugins/impex/csv/CMakeLists.txt 2019-06-01 15:10:43.725250900 +0200
++++ b/plugins/impex/csv/CMakeLists.txt 2019-06-01 15:10:43.734250666 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ # import
+
+--- a/plugins/impex/exr/CMakeLists.txt 2019-06-01 15:10:43.745250381 +0200
++++ b/plugins/impex/exr/CMakeLists.txt 2019-06-01 15:10:43.754250148 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories(SYSTEM ${OPENEXR_INCLUDE_DIR} )
+
+--- a/plugins/impex/ppm/CMakeLists.txt 2019-06-01 15:10:43.765249862 +0200
++++ b/plugins/impex/ppm/CMakeLists.txt 2019-06-01 15:10:43.773249655 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ include_directories( ${CMAKE_CURRENT_SOURCE_DIR} )
+
+--- a/plugins/impex/svg/CMakeLists.txt 2019-06-01 15:10:43.784249370 +0200
++++ b/plugins/impex/svg/CMakeLists.txt 2019-06-01 15:10:43.792249162 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritasvgimport_SOURCES
+ kis_svg_import.cc
+--- a/plugins/impex/png/CMakeLists.txt 2019-06-01 15:10:43.803248877 +0200
++++ b/plugins/impex/png/CMakeLists.txt 2019-06-01 15:10:43.811248669 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritapngimport_SOURCES
+ kis_png_import.cc
+--- a/plugins/paintops/libpaintop/CMakeLists.txt 2019-06-01 15:10:43.823248358 +0200
++++ b/plugins/paintops/libpaintop/CMakeLists.txt 2019-06-01 15:10:43.831248150 +0200
+@@ -104,4 +104,6 @@
+ install(TARGETS kritalibpaintop ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/plugins/paintops/defaultpaintops/CMakeLists.txt 2019-06-01 15:10:43.842247865 +0200
++++ b/plugins/paintops/defaultpaintops/CMakeLists.txt 2019-06-01 15:10:43.850247658 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(brush/tests)
++endif()
+
+ include_directories(brush
+ duplicate
+--- a/libs/metadata/CMakeLists.txt 2019-06-01 15:10:43.862247346 +0200
++++ b/libs/metadata/CMakeLists.txt 2019-06-01 15:10:43.870247139 +0200
+@@ -29,4 +29,6 @@
+
+ install(TARGETS kritametadata ${INSTALL_TARGETS_DEFAULT_ARGS})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/global/CMakeLists.txt 2019-06-01 15:10:43.881246854 +0200
++++ b/libs/global/CMakeLists.txt 2019-06-01 15:10:43.890246620 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include(CheckFunctionExists)
+ check_function_exists(backtrace HAVE_BACKTRACE)
+--- a/libs/ui/CMakeLists.txt 2019-06-01 15:10:43.901246335 +0200
++++ b/libs/ui/CMakeLists.txt 2019-06-01 15:10:43.911246076 +0200
+@@ -7,7 +7,9 @@
+ ${OCIO_INCLUDE_DIR}
+ )
+
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ if (APPLE)
+ find_library(FOUNDATION_LIBRARY Foundation)
+--- a/libs/flake/CMakeLists.txt 2019-06-01 15:10:43.922245790 +0200
++++ b/libs/flake/CMakeLists.txt 2019-06-01 15:10:43.931245557 +0200
+@@ -9,7 +9,9 @@
+ )
+
+ add_subdirectory(styles)
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritaflake_SRCS
+ KoGradientHelper.cpp
+--- a/libs/brush/CMakeLists.txt 2019-06-01 15:10:43.943245246 +0200
++++ b/libs/brush/CMakeLists.txt 2019-06-01 15:10:43.952245012 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(SYSTEM
+ ${EIGEN3_INCLUDE_DIR}
+--- a/libs/widgetutils/CMakeLists.txt 2019-06-01 15:10:43.963244727 +0200
++++ b/libs/widgetutils/CMakeLists.txt 2019-06-01 15:10:43.972244494 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ configure_file(xmlgui/config-xmlgui.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xmlgui.h )
+
+--- a/libs/store/CMakeLists.txt 2019-06-01 15:10:43.984244182 +0200
++++ b/libs/store/CMakeLists.txt 2019-06-01 15:10:43.992243975 +0200
+@@ -1,6 +1,8 @@
+ include_directories(${QUAZIP_INCLUDE_DIRS})
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+
+ set(kritastore_LIB_SRCS
+ KoDirectoryStore.cpp
+--- a/libs/pigment/CMakeLists.txt 2019-06-01 15:10:44.002243716 +0200
++++ b/libs/pigment/CMakeLists.txt 2019-06-01 15:10:44.010243508 +0200
+@@ -31,7 +31,9 @@
+ message("${__per_arch_factory_objs}")
+ endif()
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+ add_subdirectory(benchmarks)
+
+ set(kritapigment_SRCS
+--- a/libs/libkis/CMakeLists.txt 2019-06-01 15:10:44.021243223 +0200
++++ b/libs/libkis/CMakeLists.txt 2019-06-01 15:10:44.028243041 +0200
+@@ -47,4 +47,6 @@
+ install(TARGETS kritalibkis ${INSTALL_TARGETS_DEFAULT_ARGS})
+
+
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/image/CMakeLists.txt 2019-06-01 15:10:44.039242756 +0200
++++ b/libs/image/CMakeLists.txt 2019-06-01 15:10:44.047242548 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ add_subdirectory( tiles3 )
+
+--- a/libs/image/tiles3/CMakeLists.txt 2019-06-01 15:10:44.057242289 +0200
++++ b/libs/image/tiles3/CMakeLists.txt 2019-06-01 15:10:44.065242082 +0200
+@@ -1 +1,3 @@
++if(BUILD_TESTING)
+ add_subdirectory(tests)
++endif()
+--- a/libs/odf/CMakeLists.txt 2019-06-01 15:10:44.076241796 +0200
++++ b/libs/odf/CMakeLists.txt 2019-06-01 15:10:44.084241589 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ set(kritaodf_LIB_SRCS
+ KoOdf.cpp
+--- a/libs/widgets/CMakeLists.txt 2019-06-01 15:10:44.094241329 +0200
++++ b/libs/widgets/CMakeLists.txt 2019-06-01 15:10:44.102241122 +0200
+@@ -1,4 +1,6 @@
++if(BUILD_TESTING)
+ add_subdirectory( tests )
++endif()
+
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
diff --git a/media-gfx/krita/krita-4.2.0.ebuild b/media-gfx/krita/krita-4.2.0.ebuild
new file mode 100644
index 000000000000..3153c3eba368
--- /dev/null
+++ b/media-gfx/krita/krita-4.2.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+QT_MINIMAL="5.12.3"
+VIRTUALX_REQUIRED="test"
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit kde5 python-single-r1
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Free digital painting application. Digital Painting, Creative Freedom!"
+HOMEPAGE="https://kde.org/applications/graphics/krita/ https://krita.org/"
+LICENSE="GPL-3"
+IUSE="color-management fftw gif +gsl heif +jpeg openexr pdf qtmedia +raw tiff vc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ dev-cpp/eigen:3
+ dev-lang/perl
+ sys-devel/gettext
+"
+COMMON_DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui '-gles2' '' '5=')
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ dev-libs/boost:=
+ dev-libs/quazip
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ media-gfx/exiv2:=
+ media-libs/lcms
+ media-libs/libpng:0=
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXi
+ color-management? ( media-libs/opencolorio )
+ fftw? ( sci-libs/fftw:3.0= )
+ gif? ( media-libs/giflib )
+ gsl? ( sci-libs/gsl:= )
+ jpeg? ( virtual/jpeg:0 )
+ heif? ( media-libs/libheif:= )
+ openexr? (
+ media-libs/ilmbase:=
+ media-libs/openexr
+ )
+ pdf? ( app-text/poppler[qt5] )
+ qtmedia? ( $(add_qt_dep qtmultimedia) )
+ raw? ( media-libs/libraw:= )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ vc? ( >=dev-libs/vc-1.1.0 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !app-office/calligra:4[calligra_features_krita]
+ !app-office/calligra-l10n:4[calligra_features_krita(+)]
+"
+
+# bug 630508
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-tests-optional.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_configure() {
+ # Prevent sandbox violation from FindPyQt5.py module
+ # See Gentoo-bug 655918
+ addpredict /dev/dri
+
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package color-management OCIO)
+ $(cmake-utils_use_find_package fftw FFTW3)
+ $(cmake-utils_use_find_package gif GIF)
+ $(cmake-utils_use_find_package gsl GSL)
+ $(cmake-utils_use_find_package heif HEIF)
+ $(cmake-utils_use_find_package jpeg JPEG)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ $(cmake-utils_use_find_package pdf Poppler)
+ $(cmake-utils_use_find_package qtmedia Qt5Multimedia)
+ $(cmake-utils_use_find_package raw LibRaw)
+ $(cmake-utils_use_find_package tiff TIFF)
+ $(cmake-utils_use_find_package vc Vc)
+ )
+
+ kde5_src_configure
+}