summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-07 00:41:16 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-07 00:55:36 +0200
commitfecee9ac333f9d195e2a1bedd6683eb299140074 (patch)
treee3db2de3a9d7634ce116b32ec7bb7ea9f8f7b0f8
parentsys-apps/usbutils: Bump to version 014 (diff)
downloadgentoo-fecee9ac.tar.gz
gentoo-fecee9ac.tar.bz2
gentoo-fecee9ac.zip
dev-python/flask-nav: enable py310, update EAPI 7 -> 8
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/flask-nav/files/flask-nav-0.6-py310.patch22
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r3.ebuild33
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/flask-nav/files/flask-nav-0.6-py310.patch b/dev-python/flask-nav/files/flask-nav-0.6-py310.patch
new file mode 100644
index 000000000000..e70209498a0b
--- /dev/null
+++ b/dev-python/flask-nav/files/flask-nav-0.6-py310.patch
@@ -0,0 +1,22 @@
+From b61de7a6742f7d15f92b477b1518f420303b1efb Mon Sep 17 00:00:00 2001
+From: Jay Shepherd <shepherdjay@users.noreply.github.com>
+Date: Mon, 27 Apr 2020 12:11:48 -0600
+Subject: [PATCH] Fix deprecation warning for collections
+
+---
+ flask_nav/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/flask_nav/__init__.py b/flask_nav/__init__.py
+index 7c25dfa..9fea6ee 100644
+--- a/flask_nav/__init__.py
++++ b/flask_nav/__init__.py
+@@ -46,7 +46,7 @@ class NavbarRenderingError(Exception):
+ pass
+
+
+-class ElementRegistry(collections.MutableMapping):
++class ElementRegistry(collections.abc.MutableMapping):
+ def __init__(self):
+ self._elems = {}
+
diff --git a/dev-python/flask-nav/flask-nav-0.6-r3.ebuild b/dev-python/flask-nav/flask-nav-0.6-r3.ebuild
new file mode 100644
index 000000000000..c8f197283d11
--- /dev/null
+++ b/dev-python/flask-nav/flask-nav-0.6-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create navigation for Flask applications."
+HOMEPAGE="https://pythonhosted.org/flask-nav/"
+# docs are missing from PyPI tarballs
+# https://github.com/mbr/flask-nav/pull/12
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster
+
+PATCHES=(
+ # https://github.com/mbr/flask-nav/pull/27
+ "${FILESDIR}/${P}-py310.patch"
+)