summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-10-09 22:15:13 -0500
committerSam James <sam@gentoo.org>2020-10-10 04:58:29 +0000
commitfed7eb00df36cec72f22422b72973fe1723d5d86 (patch)
tree4b47a94d3a8a3d85a5f5fbe3d7b2f4655d3f3dcc
parentdev-libs/cloog: minor fixes (diff)
downloadgentoo-fed7eb00.tar.gz
gentoo-fed7eb00.tar.bz2
gentoo-fed7eb00.zip
media-gfx/sam2p: correct compiler configuration
Closes: https://bugs.gentoo.org/746638 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/17869 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/sam2p/files/sam2p-build-fixes.patch53
-rw-r--r--media-gfx/sam2p/files/sam2p-configure-strip.patch30
-rw-r--r--media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild (renamed from media-gfx/sam2p/sam2p-0.49.4_p20190718.ebuild)8
3 files changed, 57 insertions, 34 deletions
diff --git a/media-gfx/sam2p/files/sam2p-build-fixes.patch b/media-gfx/sam2p/files/sam2p-build-fixes.patch
new file mode 100644
index 000000000000..6a1c80175127
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-build-fixes.patch
@@ -0,0 +1,53 @@
+Make stripping configurable, correct CC/CXX/CFLAGS/CXXFLAGS handling, add
+missing include
+
+diff --git a/Makefile b/Makefile
+index 1433167..38bb7cc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,12 +28,13 @@ ifeq ($(MAKECMDGOALS),Makedep.force)
+ MAKE_DIST=000
+ endif
+
++GCC_STRIP ?= -s
+ BASH=bash
+ PERL_BADLANG=x
+ export PERL_BADLANG
+
+ CXXX=$(CXD_assert)
+-LDALL=$(LDXX) -s $(LDFLAGS) $(LIBS)
++LDALL=$(LDXX) $(GCC_STRIP) $(LDFLAGS) $(LIBS)
+ ifeq ($(ENABLE_DEBUG), no)
+ CXXX=$(CXD_no)
+ endif
+@@ -46,8 +47,8 @@ CXXX=$(CXD_checker)
+ LDALL=checkerg++ $(LDFLAGS) $(LIBS)
+ endif
+
+-CXXALL=$(CXXX) $(CXXFLAGS) $(CXXFLAGSB)
+-CCALL =$(CXXX) $(CXXFLAGS) $(CXXFLAGSB)
++CXXALL=$(CXX) $(CXXFLAGS) $(CXXFLAGSB)
++CCALL =$(CC) $(CFLAGS) $(CXXFLAGSB)
+ CXDFAL=$(CXXFLAGS) $(CXXFLAGSB) $(LDFLAGS) $(LIBS)
+
+ .PHONY: clean dist dist-noautoconf dist-more allclean distclean dist-install
+@@ -67,7 +68,7 @@ ifeq ($(MAKE_DIST),)
+ #
+ # echo to config.h is needed to make config.h younger than config.h.in;
+ # configure doesn't change the timestamp of config.h if it's unchanged.
+- Makedep config.h: configure Makehelp.in config.h.in ccdep.pl sam2p_version.h; ./configure MAKE=$(MAKE) --enable-gif --enable-lzw && echo "" >>config.h
++ Makedep config.h: configure Makehelp.in config.h.in ccdep.pl sam2p_version.h;
+ Makehelp:;
+ include Makehelp # Defines CXX. File generated by ./configure.
+ include Makedep # Contains ALL+=... .
+@@ -101,8 +102,8 @@ IDE_MODES := release debug
+ IDE_TARGETS_debug := $(patsubst %,%.yes, $(TARGETS))
+ IDE_TARGETS_release := $(TARGETS)
+
+-CXD_assert =$(CXX) -s -O2
+-CXD_no =$(CXX) -s -DNDEBUG -O3
++CXD_assert =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
++CXD_no =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
+ # CXD_yes =$(CXX) $(GFLAG) -lefence
+ CXD_yes =$(CXX) $(GFLAG)
+ CXD_checker=checkerg++ $(GFLAG)
diff --git a/media-gfx/sam2p/files/sam2p-configure-strip.patch b/media-gfx/sam2p/files/sam2p-configure-strip.patch
deleted file mode 100644
index be78fad0f736..000000000000
--- a/media-gfx/sam2p/files/sam2p-configure-strip.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 1433167..b662e33 100644
---- a/Makefile
-+++ b/Makefile
-@@ -28,12 +28,13 @@ ifeq ($(MAKECMDGOALS),Makedep.force)
- MAKE_DIST=000
- endif
-
-+GCC_STRIP ?= -s
- BASH=bash
- PERL_BADLANG=x
- export PERL_BADLANG
-
- CXXX=$(CXD_assert)
--LDALL=$(LDXX) -s $(LDFLAGS) $(LIBS)
-+LDALL=$(LDXX) $(GCC_STRIP) $(LDFLAGS) $(LIBS)
- ifeq ($(ENABLE_DEBUG), no)
- CXXX=$(CXD_no)
- endif
-@@ -101,8 +102,8 @@ IDE_MODES := release debug
- IDE_TARGETS_debug := $(patsubst %,%.yes, $(TARGETS))
- IDE_TARGETS_release := $(TARGETS)
-
--CXD_assert =$(CXX) -s -O2
--CXD_no =$(CXX) -s -DNDEBUG -O3
-+CXD_assert =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
-+CXD_no =$(CXX) $(GCC_STRIP) $(CXXFLAGS)
- # CXD_yes =$(CXX) $(GFLAG) -lefence
- CXD_yes =$(CXX) $(GFLAG)
- CXD_checker=checkerg++ $(GFLAG)
diff --git a/media-gfx/sam2p/sam2p-0.49.4_p20190718.ebuild b/media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild
index 2460983318f6..e95883c8eca7 100644
--- a/media-gfx/sam2p/sam2p-0.49.4_p20190718.ebuild
+++ b/media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild
@@ -21,7 +21,7 @@ BDEPEND="dev-lang/perl"
S="${WORKDIR}/${PN}-${COMMIT}"
-PATCHES=( "${FILESDIR}"/${PN}-configure-strip.patch )
+PATCHES=( "${FILESDIR}"/${PN}-build-fixes.patch )
src_prepare() {
default
@@ -29,15 +29,15 @@ src_prepare() {
# configure.in files are deprecated
mv configure.{in,ac} || die
- # upstream thinks they're being helpful by running configure with `make`
- sed -i '/Makedep/s/ .\/configure.*//' Makefile || die
+ # missing include for memset
+ sed -i '1s;^;#include <string.h>\n;' pts_defl.c
# eautoreconf is still needed or you get bad warnings
eautoreconf
}
src_configure() {
- tc-export CXX
+ tc-export CC CXX
econf \
--enable-lzw \