summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-03-15 15:18:55 -0400
committerCraig Andrews <candrews@gentoo.org>2023-03-15 15:19:21 -0400
commitff05983ef3aaf971ae4252cd2a8ab3c178ddeb6c (patch)
treefcf36c3d54ab16b6434e54a6c4b2fd25c80b3be0
parentsys-kernel/gentoo-sources: stabilize 4.14.309 for x86 (diff)
downloadgentoo-ff05983e.tar.gz
gentoo-ff05983e.tar.bz2
gentoo-ff05983e.zip
net-p2p/cpuminer-opt: add 3.21.5
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.21.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 9cc15dc61158..774563c7e36f 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.21.3.tar.gz 1796472 BLAKE2B cbbe7e4c93daefab6264c6d73b25e292c23edcc86d58ae6e139a5a6e2e6f354576d3264bc16b13449caa3c05422fb69fa742a990ca71dda1baaa76aa66095118 SHA512 c70e823d371158022733fa5354cf8b58f83b2588368d350b5707baab1b23ef8d5174ff5664444818659c44a97e57bf5cc8b991ab2b5307161eeca4acb7950a9b
+DIST cpuminer-opt-3.21.5.tar.gz 1795555 BLAKE2B 835b799334445c8a0b6a531b6a270f0b3e6b2f34c9f6002e08560c57eb3beefbd41ab322fd42c6a796bf295bed2d8e182a8999b771133ae555ac335039965bfa SHA512 e5aed1e9f5e181c3df76669f8c3479608ae355b5b5fd33ea1fb6c7b8338826c7a853505f975b95ce82697ed5d04b7d193c80a13a94d26e9ae7e9a42b3fc15403
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.21.5.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.5.ebuild
new file mode 100644
index 000000000000..dd862b295bd0
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}