summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-16 14:57:41 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-16 15:07:03 -0500
commitff17ff97ca9cf293666c776400087950941cdaaf (patch)
treec1c97a8b2e8bb93478807427d377125aa6993235
parentx11-libs/pango: arm64 stable (bug #692110) (diff)
downloadgentoo-ff17ff97ca9cf293666c776400087950941cdaaf.tar.gz
gentoo-ff17ff97ca9cf293666c776400087950941cdaaf.tar.bz2
gentoo-ff17ff97ca9cf293666c776400087950941cdaaf.zip
app-admin/ansible: 2.7.13 and 2.8.4 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest2
-rw-r--r--app-admin/ansible/ansible-2.7.13.ebuild66
-rw-r--r--app-admin/ansible/ansible-2.8.4.ebuild71
3 files changed, 139 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 271499869b7e..756ff2d10fb7 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,5 @@
DIST ansible-2.7.12.tar.gz 11860944 BLAKE2B 52cc79a88bbff9dc009ead8ab9f9d299420ae060e211aab23fe3bbef8c8229cd9e526dc3df518a4285cc17c1448ab4892cc3059d70bfef2fd332a44c72b57019 SHA512 0ab68af8239f6d4d2a13bd38a09fe6f3c700231e7c83df0af77c70ea62faebd0d45e1ff316963c6c72931608d49a79b98e8d3ddc6f4c8b826aabe87dc71cc6f9
+DIST ansible-2.7.13.tar.gz 11861862 BLAKE2B 3123d84b9f45bb5e50a0d5db5d0b2ae10163e2818d30f29ad5a80c23979a347eb5e17806bd295df547b88a09191918443162cb25d7f339ae76df52e3960954b0 SHA512 8dc19e5c93a90d43ced6628699d2da42d522a020bb2cdd35ba73f6286998c605852c89250af8696e94aba0080b2fab12761a39c3e2eb86d39c212a198f970652
DIST ansible-2.8.2.tar.gz 14328267 BLAKE2B 9548af73914b68374f71ab83e5a68e86e75b8ccf86066831699b147091d067a3f1e0b59d94b22b42151d90779f6d3bb39856a3d205862c933aec6bbe76824e22 SHA512 02cd8fd214f61041914abeebf2395f16acf370e110bdef0181689f604f06504902f9a05a2413877a31680528af539f078e2cd7b7f2eebe2389c9aa441b063305
DIST ansible-2.8.3.tar.gz 14343746 BLAKE2B 3859d88d8462f7109ab23c169b4a91c7a03940b5a8aaff4bfc7ab430fb533898a44221dee18f481612abe1cce1270211a34c2bc1dc7603d89adeb11e50d2b242 SHA512 cee2c663577155269c4d762816590200224e87979411dc7486f5840783f23aaa688577a3f75e272c4875af30397bb383d11eaa7d122d5f304388d5b45ffb9b6f
+DIST ansible-2.8.4.tar.gz 14348300 BLAKE2B 8a9b5587411d2366a91643682c0ef82b0aa5b5cd5e6b882f3ffdfa100c4f3995472913bc12e1c2f7077efb69ec8ac3ad168a79fc3d8c127b34ce03c69588a4c7 SHA512 9efacbaf053acb8cf92ebe5bda982794ecbdbf55e33a4a292a68874b637eebe82406bfba129adf839354ee18aa809d45d77502f68b8e8d07358a48c9b5687b7e
diff --git a/app-admin/ansible/ansible-2.7.13.ebuild b/app-admin/ansible/ansible-2.7.13.ebuild
new file mode 100644
index 000000000000..63e11740ae9c
--- /dev/null
+++ b/app-admin/ansible/ansible-2.7.13.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}
diff --git a/app-admin/ansible/ansible-2.8.4.ebuild b/app-admin/ansible/ansible-2.8.4.ebuild
new file mode 100644
index 000000000000..851a6fa4e715
--- /dev/null
+++ b/app-admin/ansible/ansible-2.8.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_prepare_all() {
+ rm -fv MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}