summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Fröhning <misanthropos@gmx.net>2020-10-07 10:40:25 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-10-07 10:40:25 +0300
commitff3bd31b2d8f7d8e7ad23681e3f2766f53d369f3 (patch)
tree6481e18140e023ecd903206eb2713806013946bb
parentnet-libs/nodejs: Old (diff)
downloadgentoo-ff3bd31b.tar.gz
gentoo-ff3bd31b.tar.bz2
gentoo-ff3bd31b.zip
x11-misc/revelation: re-add last-rited package
A password manager for GNOME - new maintainer, - ported to meson, hence dropped KEYWORDS, - python3 support. Signed-off-by: Richard Fröhning <misanthropos@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/17750 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-misc/revelation/Manifest1
-rw-r--r--x11-misc/revelation/metadata.xml12
-rw-r--r--x11-misc/revelation/revelation-0.5.4.ebuild50
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-misc/revelation/Manifest b/x11-misc/revelation/Manifest
new file mode 100644
index 000000000000..9780704989a4
--- /dev/null
+++ b/x11-misc/revelation/Manifest
@@ -0,0 +1 @@
+DIST revelation-0.5.4.tar.xz 282600 BLAKE2B 519b01252b82acf0e927a9d19783792f83822cc1f1a4c3be4af3678d5446f8012d993e12397f44aae616aca88257970de7391a1269e24cc1ebc08275d0c962ed SHA512 bd536f6c03e443d91a20606765b661dc54f3e4c1f45d060d3829a894a31e553a61785bb31d7508267abd66e057fc1d93f1716ed1b553566d92a2580ad696606f
diff --git a/x11-misc/revelation/metadata.xml b/x11-misc/revelation/metadata.xml
new file mode 100644
index 000000000000..2a6c92d969d5
--- /dev/null
+++ b/x11-misc/revelation/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>misanthropos@gmx.net</email>
+ <name>Richard Fröhning</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/revelation/revelation-0.5.4.ebuild b/x11-misc/revelation/revelation-0.5.4.ebuild
new file mode 100644
index 000000000000..0f47118e8de8
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.5.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit gnome2-utils python-single-r1 meson xdg
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="https://revelation.olasagasti.info/ https://github.com/mikelolasagasti/revelation"
+SRC_URI="https://github.com/mikelolasagasti/revelation/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Upstream does not provide any test suite.
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycryptodomex[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-libs/libpwquality[python,${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3
+ dev-libs/glib
+ dev-libs/gobject-introspection
+"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}