summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@standard.ai>2019-09-01 23:18:00 -0700
committerLuca Barbato <lu_zero@gentoo.org>2019-09-07 13:34:09 +0000
commitff3bf49e8e62304f623003dcb010002d29ad9221 (patch)
tree97b11bd17ee0b9c89243ae159593f4ed280b5d8d
parentmedia-video/aravis: add myself as maintainer (diff)
downloadgentoo-ff3bf49e.tar.gz
gentoo-ff3bf49e.tar.bz2
gentoo-ff3bf49e.zip
media-video/aravis: bump 0.6.4
Closes: https://bugs.gentoo.org/693304 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
-rw-r--r--media-video/aravis/Manifest1
-rw-r--r--media-video/aravis/aravis-0.6.4.ebuild85
-rw-r--r--media-video/aravis/metadata.xml47
3 files changed, 109 insertions, 24 deletions
diff --git a/media-video/aravis/Manifest b/media-video/aravis/Manifest
index 951af5ec2643..cceae36b0a52 100644
--- a/media-video/aravis/Manifest
+++ b/media-video/aravis/Manifest
@@ -1,2 +1,3 @@
DIST aravis-0.5.10.tar.xz 540700 BLAKE2B f12a2bfa2bf8ac1875b28ec0549e5ebe3e5eb1cd646e417acc52a760546343893e19d7fb13741799346286dc69d9ecf2a7d7a3c9ada6ffefafab5c6450468848 SHA512 27a182a8fce66416e14baa16609b91307683613fab9324c96f94b9a7dd956ba0d60f5c966b2ec5184374ab8f9f527ad4d7733dffd2c40faa409ff196c344eb29
DIST aravis-0.6.1.tar.xz 547700 BLAKE2B 7230cf49e08865b6f4e6621585c394633c54b94b921e4c686757eb21a02d5f51406f5084f92d41ad1880468001c908eb648fd2c2247def46bcbceea92bffa3ce SHA512 098a079c7efc5e5f9d198beef8a6271f525779947d1767eba81262a33c38afa6d9f01f254e25b714b9c74550795beed144bb463c0e14d2a46e6e96d1af19bde4
+DIST aravis-0.6.4.tar.gz 2972111 BLAKE2B b7f1c4da08bb4e7d11faffcd4ef90b7215b803e5e74ba1730388e04304685b761024ffea49b082c94e3fddc9dc65201545167a277b1088ad7273d41d50fae5b0 SHA512 6090fd730ad9fe8e1641e48c52189e8961bf03a88cefb57135a2de985c2ca607c21b05d472a60586976aa1e05ba2121246b06b75179dd3241e1f703aad8dd7be
diff --git a/media-video/aravis/aravis-0.6.4.ebuild b/media-video/aravis/aravis-0.6.4.ebuild
new file mode 100644
index 000000000000..0f78ce56983b
--- /dev/null
+++ b/media-video/aravis/aravis-0.6.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit meson xdg
+
+DESCRIPTION="Library for video acquisition using Genicam cameras"
+HOMEPAGE="https://github.com/AravisProject/aravis"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AravisProject/${PN}"
+else
+ MY_P="${PN^^}_${PV//./_}"
+ SRC_URI="https://github.com/AravisProject/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+# FIXME: As of right now tests are always built, once that changes a USE flag
+# should be added. c.f. https://github.com/AravisProject/aravis/issues/286
+IUSE="doc fast-heartbeat gstreamer introspection packet-socket usb X"
+
+GST_DEPEND="
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+"
+BDEPEND="
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="
+ >=dev-libs/glib-2.34
+ dev-libs/libxml2:=
+ sys-libs/zlib:=
+ gstreamer? ( ${GST_DEPEND} )
+ packet-socket? ( sys-process/audit )
+ usb? ( virtual/libusb:1 )
+ X? (
+ ${GST_DEPEND}
+ >=x11-libs/gtk+-3.12:3
+ x11-libs/libnotify
+ )
+"
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} != 9999 ]]; then
+ S="${WORKDIR}/${PN}-${MY_P}"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc documentation)
+ $(meson_use fast-heartbeat)
+ $(meson_use gstreamer gst-plugin)
+ $(meson_use introspection)
+ $(meson_use packet-socket)
+ $(meson_use usb)
+ $(meson_use X viewer)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # Aravis appends the major and min versions (but not the patch) to it's
+ # binaries and it's folder in /usr/share. Things then end up like
+ # `arv-tool-0.6`. We use this little hack to find out the version of the
+ # current build in a way that works even for a -9999 ebuild.
+ local install_pv="$(ls ${ED}/usr/share | grep aravis- | cut -f 2 -d '-')"
+ local install_p="${PN}-${install_pv}"
+
+ # Properly place icons
+ if use X; then
+ cp -r "${ED}/usr/share/${install_p}/icons" "${ED}/usr/share" || die "Failed to copy icons"
+ fi
+
+ # Symlink versioned binaries to non-versioned
+ dosym "arv-tool-${install_pv}" "usr/bin/arv-tool"
+ dosym "arv-fake-gv-camera-${install_pv}" "usr/bin/arv-fake-gv-camera"
+ use X && dosym "arv-viewer-${install_pv}" "usr/bin/arv-viewer"
+}
diff --git a/media-video/aravis/metadata.xml b/media-video/aravis/metadata.xml
index b22557417242..0ea071b7518a 100644
--- a/media-video/aravis/metadata.xml
+++ b/media-video/aravis/metadata.xml
@@ -1,28 +1,27 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>bernardo@standard.ai</email>
- <name>Bernardo Meurer</name>
- </maintainer>
- <maintainer type="person">
- <email>lu_zero@gentoo.org</email>
- </maintainer>
-
- <maintainer type="project">
- <email>media-video@gentoo.org</email>
- <name>Gentoo Video project</name>
- </maintainer>
-
- <use>
- <flag name="X">
- Build the GTK+-based video viewer for aravis. This requires
- GStreamer and a few plugins but technically not the GST plugin
- for aravis.
- </flag>
-
- <flag name="gstreamer">
- Build the GStreamer plugin for aravis, but not the video viewer.
- </flag>
- </use>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>lu_zero@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>media-video@gentoo.org</email>
+ <name>Gentoo Video project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Aravis is a glib/gobject based library for video acquisition using Genicam
+ cameras. It currently implements the gigabit ethernet and USB3 protocols
+ used by industrial cameras. It also provides a basic ethernet camera
+ simulator and a simple video viewer.
+ </longdescription>
+ <use>
+ <flag name="X"> Build the GTK+-based video viewer.</flag>
+ <flag name="fast-heartbeat"> Enable faster heartbeat rate. </flag>
+ <flag name="gstreamer"> Build the GStreamer plugin.</flag>
+ <flag name="packet-socket"> Enable packet socket support.</flag>
+ </use>
</pkgmetadata>