summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-01 07:39:07 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-01 07:55:35 +0000
commitff5d2b93fb62c934b8e54d5a83db44c7fd3abdca (patch)
treeca431080ff5f2e2f3b6afc9973b609e4646d6205
parentdev-java/netty-transport: Version bump. (diff)
downloadgentoo-ff5d2b93.tar.gz
gentoo-ff5d2b93.tar.bz2
gentoo-ff5d2b93.zip
dev-java/netty-codec: Version bump.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-java/netty-codec/Manifest1
-rw-r--r--dev-java/netty-codec/files/netty-codec-4.0.22-build.xml258
-rw-r--r--dev-java/netty-codec/netty-codec-4.0.22.ebuild56
3 files changed, 315 insertions, 0 deletions
diff --git a/dev-java/netty-codec/Manifest b/dev-java/netty-codec/Manifest
index 2665155da82f..461190c8be8f 100644
--- a/dev-java/netty-codec/Manifest
+++ b/dev-java/netty-codec/Manifest
@@ -1,2 +1,3 @@
DIST netty-4.0.19.Final.tar.gz 929126 SHA256 065980d0232179a02dc52d55e9017f485c2cbcf14597172cac3bfd2db5dce9ac SHA512 031a251c93b2c475bbf12610f297ed47eacc430ba19e05fd33c12ab768b1d14556cb59d0f9e2a19f87c325b516323cd2ec13a341522825a19d76c27abb13a4cf WHIRLPOOL 8a2c026c62de3a26ef0c432af37b193b10bc826429399dc8fb8016d50cb22359e50087a10edecd69924861bf1f29da02b39810f37db514ba260a1ea9ef2692d0
DIST netty-4.0.21.Final.tar.gz 960489 SHA256 e1b5572defaa760dcd8ded4d7691e9daf242b2e1885115b722f2f790d9ef9f75 SHA512 5d432e9e433c22b82e67ed3463c6982ca95c2ad823165e1ca9a5046e598878f06aac4221be235f2bda15edfdb22028f2a4f74fb37d431f24a2636e4ec60fae74 WHIRLPOOL 92e96986def775f26286958a9e2c7fe55ab571ad373f9cc25357db71f85f170d7aba7d7854c130c5788f7332665000cd10f666fff06abd0ce57cf4f95008958a
+DIST netty-4.0.22.Final.tar.gz 983956 SHA256 d539483235223804d76f8da572b851cd196254f5da7d3ac8e064c626b31748ff SHA512 f216c8431e663533ea5258bc054154d07f791667712c4dd619eae5de55c1b9031cca756a26b49d8a0bb9e3cf61ca5cb295e7a3b3e4e9e98e99cd53963d54912e WHIRLPOOL ca3d9a9b78643414b4361388e8486ab7cbb7d4a479718d89a8f51d90ef7fd580b154f09d1e8014503bececd49fb8841782e933c8cc8f355609ccae1f6510ccc5
diff --git a/dev-java/netty-codec/files/netty-codec-4.0.22-build.xml b/dev-java/netty-codec/files/netty-codec-4.0.22-build.xml
new file mode 100644
index 000000000000..938e196de1df
--- /dev/null
+++ b/dev-java/netty-codec/files/netty-codec-4.0.22-build.xml
@@ -0,0 +1,258 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/15/14 7:12 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="netty-codec-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="netty-codec-4.0.22.Final"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/io/netty/netty-transport/4.0.19.Final/netty-transport-4.0.19.Final.jar"/>
+ <pathelement location="${maven.repo.local}/io/netty/netty-buffer/4.0.19.Final/netty-buffer-4.0.19.Final.jar"/>
+ <pathelement location="${maven.repo.local}/io/netty/netty-common/4.0.19.Final/netty-common-4.0.19.Final.jar"/>
+ <pathelement location="${maven.repo.local}/com/google/protobuf/protobuf-java/2.5.0/protobuf-java-2.5.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/jboss/marshalling/jboss-marshalling/1.3.18.GA/jboss-marshalling-1.3.18.GA.jar"/>
+ <pathelement location="${maven.repo.local}/com/jcraft/jzlib/1.1.2/jzlib-1.1.2.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/io/netty/netty-transport/4.0.19.Final/netty-transport-4.0.19.Final.jar"/>
+ <pathelement location="${maven.repo.local}/io/netty/netty-buffer/4.0.19.Final/netty-buffer-4.0.19.Final.jar"/>
+ <pathelement location="${maven.repo.local}/io/netty/netty-common/4.0.19.Final/netty-common-4.0.19.Final.jar"/>
+ <pathelement location="${maven.repo.local}/com/google/protobuf/protobuf-java/2.5.0/protobuf-java-2.5.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/jboss/marshalling/jboss-marshalling/1.3.18.GA/jboss-marshalling-1.3.18.GA.jar"/>
+ <pathelement location="${maven.repo.local}/com/jcraft/jzlib/1.1.2/jzlib-1.1.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/jboss/marshalling/jboss-marshalling-serial/1.3.18.GA/jboss-marshalling-serial-1.3.18.GA.jar"/>
+ <pathelement location="${maven.repo.local}/org/jboss/marshalling/jboss-marshalling-river/1.3.18.GA/jboss-marshalling-river-1.3.18.GA.jar"/>
+ <pathelement location="${maven.repo.local}/org/javassist/javassist/3.18.0-GA/javassist-3.18.0-GA.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymock/3.2/easymock-3.2.jar"/>
+ <pathelement location="${maven.repo.local}/cglib/cglib-nodep/2.2.2/cglib-nodep-2.2.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/objenesis/objenesis/1.3/objenesis-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymockclassextension/3.2/easymockclassextension-3.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/jmock/jmock-junit4/2.6.0/jmock-junit4-2.6.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/jmock/jmock/2.6.0/jmock-2.6.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-library/1.1/hamcrest-library-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit-dep/4.4/junit-dep-4.4.jar"/>
+ <pathelement location="${maven.repo.local}/ch/qos/logback/logback-classic/1.0.13/logback-classic-1.0.13.jar"/>
+ <pathelement location="${maven.repo.local}/ch/qos/logback/logback-core/1.0.13/logback-core-1.0.13.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.7.5/slf4j-api-1.7.5.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="true"
+ memoryInitialSize="1024m"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="true"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="true"
+ memoryInitialSize="1024m"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test*.java"/>
+ <include name="**/*Benchmark*.java"/>
+ <exclude name="**/Abstract*"/>
+ <exclude name="**/TestUtil*"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/Abstract*"/>
+ <exclude name="**/TestUtil*"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="false"
+ use="true"
+ author="false"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="true"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/netty-codec/netty-codec-4.0.22.ebuild b/dev-java/netty-codec/netty-codec-4.0.22.ebuild
new file mode 100644
index 000000000000..876c6672fe7f
--- /dev/null
+++ b/dev-java/netty-codec/netty-codec-4.0.22.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="netty"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Async event-driven framework for rapid development of high performance network applications"
+HOMEPAGE="http://netty.io/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${MY_P}.Final.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CDEPEND="dev-java/${MY_PN}-buffer:0
+ dev-java/${MY_PN}-common:0
+ dev-java/${MY_PN}-transport:0
+ dev-java/jboss-marshalling:0
+ dev-java/jzlib:1.1.3
+ dev-libs/protobuf[java]"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${MY_P}.Final/${PN/${MY_PN}-}"
+
+EANT_BUILD_TARGET="package"
+EANT_GENTOO_CLASSPATH="${MY_PN}-buffer,${MY_PN}-common,jboss-marshalling,${MY_PN}-transport,jzlib-1.1.3,protobuf"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+# [junit] Testcase: testZLIB_OR_NONE2 took 0.008 sec
+# [junit] Caused an ERROR
+# [junit] null
+# [junit] java.lang.InstantiationException
+# [junit] at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
+RESTRICT="test"
+
+src_install() {
+ java-pkg_newjar target/${MY_PN}-*.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}