summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 04:23:26 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 04:31:01 +0100
commitff71ef9016a49257e920b54b0cc46f71550fdfad (patch)
treeeff8249879ac37da1a216b631fec70f90a88935c
parentdev-python/pytest-lazy-fixtures: Bump to 1.0.7 (diff)
downloadgentoo-ff71ef9016a49257e920b54b0cc46f71550fdfad.tar.gz
gentoo-ff71ef9016a49257e920b54b0cc46f71550fdfad.tar.bz2
gentoo-ff71ef9016a49257e920b54b0cc46f71550fdfad.zip
dev-python/referencing: Bump to 0.34.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/referencing/Manifest1
-rw-r--r--dev-python/referencing/referencing-0.34.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/referencing/Manifest b/dev-python/referencing/Manifest
index fdbc93c2f21c..cfcb4e6113e7 100644
--- a/dev-python/referencing/Manifest
+++ b/dev-python/referencing/Manifest
@@ -1 +1,2 @@
DIST referencing-0.33.0.tar.gz 55507 BLAKE2B 6781b3295a1727ed0d6cdb17ca9b8e63d974463ccebb6064cb153a5523a7912c41525d03b8baa7eb17e4165880b75a738648a318a9415be5d9d6459622ed5803 SHA512 053ae200401c415a887ebead387d3378ead4c1c98d7f37a0130fd5b8d0c9ce86848591f8e47e59e0e2d0a596a49a450fdad3ffb5246b369ffdc4f2c31e9edddd
+DIST referencing-0.34.0.tar.gz 62624 BLAKE2B c5e8a5d19121f2d09ea443248690e2fa9069140b027b6fa2f741d5133c931da12ae87d8ac7923bfc52ca3d93c966399cf48c1f31d6f4066b6a44488ec50b5d24 SHA512 97e4cfe0fb306068abfd6c0348d12483cbd3705c0b4c8852c0f0209c4d05be08bf77fa3ec56af77a2815a4ff3294ff06d3f09f213a165ae17bdcab246e47c178
diff --git a/dev-python/referencing/referencing-0.34.0.ebuild b/dev-python/referencing/referencing-0.34.0.ebuild
new file mode 100644
index 000000000000..9bb63870e54d
--- /dev/null
+++ b/dev-python/referencing/referencing-0.34.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cross-specification JSON referencing (JSON Schema, OpenAPI...)"
+HOMEPAGE="
+ https://github.com/python-jsonschema/referencing/
+ https://pypi.org/project/referencing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest