summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-06 21:49:37 +0530
committerSam James <sam@gentoo.org>2023-07-06 21:59:58 +0100
commitff77eb3bccbb3e458eb5ecfd5ffec7903acd27a3 (patch)
tree6d90bf14c76ae199689955540581c7622532a13f
parentx11-themes/numix-icon-theme-circle: drop 21.05.31 (diff)
downloadgentoo-ff77eb3bccbb3e458eb5ecfd5ffec7903acd27a3.tar.gz
gentoo-ff77eb3bccbb3e458eb5ecfd5ffec7903acd27a3.tar.bz2
gentoo-ff77eb3bccbb3e458eb5ecfd5ffec7903acd27a3.zip
net-irc/irssi: Fix usage of $type in ExtUtils::ParseXS 3.50
With recent dev-lang/perl upgrade, some of the scripts are failing to load. This patch taken from upstream should fix that. Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31781 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-irc/irssi/files/irssi-1.4.4-fix-usage-of-type-in-ExtUtils.patch43
-rw-r--r--net-irc/irssi/irssi-1.4.4-r1.ebuild72
-rw-r--r--net-irc/irssi/irssi-9999.ebuild4
3 files changed, 119 insertions, 0 deletions
diff --git a/net-irc/irssi/files/irssi-1.4.4-fix-usage-of-type-in-ExtUtils.patch b/net-irc/irssi/files/irssi-1.4.4-fix-usage-of-type-in-ExtUtils.patch
new file mode 100644
index 000000000000..517618e15098
--- /dev/null
+++ b/net-irc/irssi/files/irssi-1.4.4-fix-usage-of-type-in-ExtUtils.patch
@@ -0,0 +1,43 @@
+https://patch-diff.githubusercontent.com/raw/irssi/irssi/pull/1474.patch
+From: Ailin Nemui <ailin@d5421s.localdomain>
+Date: Tue, 4 Jul 2023 10:27:09 +0200
+Subject: [PATCH] fix usage of $type in ExtUtils::ParseXS 3.50
+
+--- a/src/perl/common/typemap
++++ b/src/perl/common/typemap
+@@ -28,5 +28,5 @@ T_IrssiObj
+ $arg = iobject_bless((SERVER_REC *)$var);
+
+ T_PlainObj
+- $arg = plain_bless($var, \"$type\");
++ $arg = plain_bless($var, \"$ntype\");
+
+--- a/src/perl/irc/typemap
++++ b/src/perl/irc/typemap
+@@ -36,5 +36,5 @@ T_DccObj
+ $arg = simple_iobject_bless((DCC_REC *)$var);
+
+ T_PlainObj
+- $arg = plain_bless($var, \"$type\");
++ $arg = plain_bless($var, \"$ntype\");
+
+--- a/src/perl/textui/typemap
++++ b/src/perl/textui/typemap
+@@ -18,7 +18,7 @@ T_BufferLineWrapper
+ OUTPUT
+
+ T_PlainObj
+- $arg = plain_bless($var, \"$type\");
++ $arg = plain_bless($var, \"$ntype\");
+
+ T_BufferLineWrapper
+ $arg = perl_buffer_line_bless($var);
+--- a/src/perl/ui/typemap
++++ b/src/perl/ui/typemap
+@@ -13,5 +13,5 @@ T_PlainObj
+ OUTPUT
+
+ T_PlainObj
+- $arg = plain_bless($var, \"$type\");
++ $arg = plain_bless($var, \"$ntype\");
+
diff --git a/net-irc/irssi/irssi-1.4.4-r1.ebuild b/net-irc/irssi/irssi-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..0a53a51c01ca
--- /dev/null
+++ b/net-irc/irssi/irssi-1.4.4-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GENTOO_DEPEND_ON_PERL="no"
+inherit perl-module meson
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support"
+HOMEPAGE="https://irssi.org/"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ # Keep for _rc compability
+ MY_P="${P/_/-}"
+
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_/-}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="otr +perl selinux +proxy"
+
+RDEPEND="
+ >=dev-libs/glib-2.6.0
+ dev-libs/openssl:=
+ sys-libs/ncurses:=
+ otr? (
+ >=dev-libs/libgcrypt-1.2.0:=
+ >=net-libs/libotr-4.1.0
+ )
+ perl? ( dev-lang/perl:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ virtual/pkgconfig"
+RDEPEND+=" selinux? ( sec-policy/selinux-irc )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-usage-of-type-in-ExtUtils.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
+ -Dwith-perl-lib=vendor
+ -Dwith-otr=$(usex otr)
+ -Dwith-proxy=$(usex proxy)
+ -Dwith-perl=$(usex perl)
+
+ # Carried over from autotools (for now?), bug #677804
+ -Ddisable-utf8proc=yes
+ -Dwith-fuzzer=no
+ -Dinstall-glib=no
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ # We don't want perl-module's src_test
+ meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ use perl && perl_delete_localpod
+}
diff --git a/net-irc/irssi/irssi-9999.ebuild b/net-irc/irssi/irssi-9999.ebuild
index 40772b5198b3..c5cc0db2269a 100644
--- a/net-irc/irssi/irssi-9999.ebuild
+++ b/net-irc/irssi/irssi-9999.ebuild
@@ -39,6 +39,10 @@ BDEPEND="dev-lang/perl
virtual/pkgconfig"
RDEPEND+=" selinux? ( sec-policy/selinux-irc )"
+PATCHES=(
+ "${FILESDIR}/${PN}-fix-usage-of-\$type-in-ExtUtils.patch"
+)
+
src_configure() {
local emesonargs=(
-Ddocdir="${EPREFIX}"/usr/share/doc/${PF}