summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-26 14:10:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-26 14:31:41 +0200
commitff82dcbcc266a5b810c75ec5724645412522c762 (patch)
tree6a6eb28b72f7fb0710e00917cfedc69b2e536270
parentdev-python/tox: Remove old (diff)
downloadgentoo-ff82dcbcc266a5b810c75ec5724645412522c762.tar.gz
gentoo-ff82dcbcc266a5b810c75ec5724645412522c762.tar.bz2
gentoo-ff82dcbcc266a5b810c75ec5724645412522c762.zip
dev-python/reportlab: Bump to 4.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-4.0.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 305693d24329..92caf1eee749 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,2 +1,3 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-4.0.4.tar.gz 3132866 BLAKE2B eb1791b248c8c0dc194781ca09dbf181dc20f745ce2fdd3a4627ae027b21baddc0bea56c6e5eefd5905f7656c5a3a388d90310ce53a948ab0a3dbaff569f2d63 SHA512 7d79f6258672523bee50256b5b15e336801fc42f290fa2ed5ed0ab355c9f2903c9210bb935c9c00fa74174072232402247c923268ede5d61ca62493d0faa2844
+DIST reportlab-4.0.5.tar.gz 3665115 BLAKE2B 9d510c1657cb0be936ddbfd92921f7d34e540d7f6b79febb126af813452d9b1f100111469f7c44e32f83dbb0c256bb590d41c7639bc2837e832c43dad030d62f SHA512 367c4ca70fd4a016a6cb08fd992174029c10a30b71e5034f0523f4dfbfef967b699c1608a3a0502b900da35fb752deb2f2e1950f394df3813d9e139f0b5946d3
diff --git a/dev-python/reportlab/reportlab-4.0.5.ebuild b/dev-python/reportlab/reportlab-4.0.5.ebuild
new file mode 100644
index 000000000000..0826a91d23ce
--- /dev/null
+++ b/dev-python/reportlab/reportlab-4.0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/
+"
+SRC_URI+="
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_sphinx docs/source
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+src_configure() {
+ cat > local-setup.cfg <<-EOF || die
+ [OPTIONS]
+ no-download-t1-files = 1
+ EOF
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py --post-install --verbosity=2 ||
+ die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}