summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-21 06:53:52 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-21 07:45:55 +0100
commitff90c620294e7b6a9c952c539972dd3231fc5efe (patch)
tree4ca0eab35fbc2e21b0115f9a704c3962b31b657e
parentdev-python/dask: Disable Python < 3.10 (diff)
downloadgentoo-ff90c620294e7b6a9c952c539972dd3231fc5efe.tar.gz
gentoo-ff90c620294e7b6a9c952c539972dd3231fc5efe.tar.bz2
gentoo-ff90c620294e7b6a9c952c539972dd3231fc5efe.zip
dev-python/s3transfer: Disable Python < 3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild b/dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..fb661e81e32a
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.6.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="
+ https://github.com/boto/s3transfer/
+ https://pypi.org/project/s3transfer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-1.24.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{unit,functional}
+}