summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-05-29 22:34:48 +0000
committerPatrice Clement <monsieurp@gentoo.org>2017-05-30 23:36:56 +0200
commitff936e8178fbe8842a20685a55d851833b7b6724 (patch)
treef39dec6010ab396048404d0a2854333f0fa688ab
parentx11-misc/qt5ct: remove old (diff)
downloadgentoo-ff936e81.tar.gz
gentoo-ff936e81.tar.bz2
gentoo-ff936e81.zip
app-backup/restic: version bump to 0.6.0.
Closes: https://github.com/gentoo/gentoo/pull/4804
-rw-r--r--app-backup/restic/Manifest1
-rw-r--r--app-backup/restic/restic-0.6.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index 3e5d02e3d77a..5959e7dc8c99 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1,2 +1,3 @@
DIST restic-0.4.0.tar.gz 22926188 SHA256 746dbc7b73f5a542be57b71714b243266a011f1d750f56f5100c08a59df1aeac SHA512 ccd15f010f8da3bae3d33698e70ff1d9565f52fb56991b78d35f95493417a4ab050021153d81c424947233255d9553d050f7a66e1c709843fe3b2d323a81f85b WHIRLPOOL 94e6b9ed777a86cb6e46cf734b9280e68cc2ce1ea061c8a94409dca594add1ec24fb736a56e35571302ff5043a60bef7f60ff3b39b038ee128bc815f7d3d48cd
DIST restic-0.5.0.tar.gz 22937327 SHA256 a8e99087478a076b8a9c7c74d37cd23a56224d8c9b242c171756784ade024fda SHA512 571e4b0aa92a6cd9320f48c46a4b2190576d9328169d54762747dfa024ab280fb41ee377b59f0114d89ebd50bc54488a8cb5e2b36c57959202e848394107bb3c WHIRLPOOL 19fef25a6e2dff3145a6700abb581e7cae3abe5522ee0197f56a572d499824e84ba25a3111c5e71856ffac18d75622766c74c585a44b6db489468050e1c8d59a
+DIST restic-0.6.0.tar.gz 25230508 SHA256 3876532e2a95a889713dcc6119fc86fa619b884dd27555951595b7d12ee56b12 SHA512 de77beeaf5dd1a10033ffdfd8754426c650f990722085622d1db7c5fd033806899dfde2557b7d4257e2894eaaaae1923dd18439d61bcca4e4e479812ff2543ea WHIRLPOOL 81c1d6c6d12de622ec53d57d9a26014f78f08c5c2bdb2982f6bfd8ead2bfd2faf4f38534426faea10a3b37bf9d37277f6a42edb02cd659e13ac5b70d03c5d8c4
diff --git a/app-backup/restic/restic-0.6.0.ebuild b/app-backup/restic/restic-0.6.0.ebuild
new file mode 100644
index 000000000000..0327682e476f
--- /dev/null
+++ b/app-backup/restic/restic-0.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="restic is a backup program that is fast, efficient and secure"
+HOMEPAGE="https://restic.github.io/"
+SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( README.rst CONTRIBUTING.md doc/design.rst doc/faq.rst doc/index.rst doc/manual.rst
+ doc/rest_backend.rst doc/development.rst doc/talks.rst doc/tutorial_aws_s3.rst doc/installation.rst )
+
+DEPEND="dev-lang/go
+ test? ( sys-fs/fuse )"
+
+RDEPEND="sys-fs/fuse"
+
+src_compile() {
+ local mygoargs=(
+ -v
+ -work
+ -x
+ -tags release
+ -ldflags "-w -X main.version=${PV}"
+ -o "${S}"/restic cmds/restic
+ )
+
+ GOPATH="${S}:${S}/vendor" go build "${mygoargs[@]}" || die
+}
+
+src_test() {
+ GOPATH="${S}:${S}/vendor" go test -v -work -x restic/... cmds/... || die
+}
+
+src_install() {
+ dobin restic
+ einstalldocs
+}