summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-04 23:00:23 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-04 23:29:37 +0200
commitffa9cf44c5ff90a63121ed0fed6ba0aa89078e6e (patch)
treeaceb1b5e3491f1638a0f3e445984572f67e285cb
parentdev-python/sphinx-autodoc-typehints: add 1.13.1 (diff)
downloadgentoo-ffa9cf44.tar.gz
gentoo-ffa9cf44.tar.bz2
gentoo-ffa9cf44.zip
dev-python/pyghmi: add 1.5.32
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pyghmi/Manifest1
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.32.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 15bc3b9f46fb..f09b206131e0 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,2 +1,3 @@
DIST pyghmi-1.5.22.tar.gz 221963 BLAKE2B 6705e904c481ddbb241fc8f8089e6bc9bcc142bfca9aaa518b2293b5dd387113fa4bbb418e748584f69fac5e8d1049d669eb73d24463adaaec3a891cae98f928 SHA512 cc665f8b9f4a0c9c127b9e895ba62e650cdb589f5c9edae6accaa5558f347d31725e8da446fcafb4f71ffadc17121d8b293160413f4a41055cb1720e9fa1ecde
DIST pyghmi-1.5.31.tar.gz 236574 BLAKE2B 9ee7250bae2d87f552686845ae3056f0f646cd1a383587c195bfcc6dfa476b8582509c909f0008fc6751295e2e4e7d33bf822e8b529d67306fcc85412fc9af22 SHA512 d7c9c05b51780bef9d2b417c1a586f84ec87a9f1ff578ab019bfdc1a462decd907b2634fb1c830d0e369eb97122bfcba62ce79a4386c73c9854cde8f9fdeb65c
+DIST pyghmi-1.5.32.tar.gz 236662 BLAKE2B e2a58d1eb9c5000d1a7f6b795836fa617ac0847ff2e7c817a6bd65ffb9a1162546a25f890ba20400e4c8d5f72dda538f696c17a35542506cc171b80f99cb5a30 SHA512 b30ad1e200d23ed99280794e4e8e12c1a2412daa27e435183edbdcf57cb1d8ace8790845dd5ab0579f2a22b26eabc11e1d1f5845fb94fed019f461b9419d2763
diff --git a/dev-python/pyghmi/pyghmi-1.5.32.ebuild b/dev-python/pyghmi/pyghmi-1.5.32.ebuild
new file mode 100644
index 000000000000..8c831160b805
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.32.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack-archive/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest