summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-25 06:48:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-25 07:54:05 +0200
commitffbb3726bdfdb63d4a2df8951b315d50163c99ea (patch)
tree86339f953a9db92950011b27df00cae89d38dcdb
parentdev-python/pytest: Bump to 7.4.3 (diff)
downloadgentoo-ffbb3726bdfdb63d4a2df8951b315d50163c99ea.tar.gz
gentoo-ffbb3726bdfdb63d4a2df8951b315d50163c99ea.tar.bz2
gentoo-ffbb3726bdfdb63d4a2df8951b315d50163c99ea.zip
dev-python/trimesh: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.0.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 027f23650977..756895073e36 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,2 +1,3 @@
DIST trimesh-3.23.5.gh.tar.gz 12720153 BLAKE2B ef37eed712eb121529bf6bc724f96456a4dc86c7265b19d77a1bf578d2b5ffae043b5c3e0a03ad5be680125fcfced65ef933037defdc582e81d52b13ac11e9a9 SHA512 52783fe1c275aa121f412d5e2846d0d985e242a33e9c446e8bef538a53ba93b1f2e133e33e4f26390e1146ad8415c28fb146b2c74524c2aa20426819b1b875a0
DIST trimesh-4.0.0.gh.tar.gz 12921048 BLAKE2B 7592ba10b57aa5cafd47311a430f881cc1ecc917f503e0cea75b38d350738d35c937e1006f80a0acc8a54a33e55f41af3d6cf280751b82a932bd2428af12e033 SHA512 1f5c1a3e92d6bda2ed37e5c6ece9fde798a2c2766c816cbb6a8bf9fdbf489f733ea3988429107eb92043f723bc222348ffe9286663a03562834ae83391793257
+DIST trimesh-4.0.1.gh.tar.gz 12922631 BLAKE2B 81cad4efea89c308f9cbb749b2515ed51f9fc87bbd37505ab94c08698f257c7f3a1b04e1b4a919bf529ee47d7531ecd605dd613c68b13fdaf853161811dfd1e6 SHA512 bfe56b3cfc94fcaa066b953e6df4c70da6fe9a99a6230d7201196a7df897a386c3425ad1da3cc7df75fa0d888fd05d07bf14e6b579a04dddab813c3858f904ef
diff --git a/dev-python/trimesh/trimesh-4.0.1.ebuild b/dev-python/trimesh/trimesh-4.0.1.ebuild
new file mode 100644
index 000000000000..06f82a59ea08
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" sci-libs/scikit-image
+}