summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 00:26:09 +0000
committerSam James <sam@gentoo.org>2022-11-04 00:26:09 +0000
commitffbbaca7c37935cdba402d50a03bd27b2cf01f6c (patch)
treec3f39f1518c5acbd9c7f8b152edc050fc6da51a4
parentdev-python/scipy: fix pkg_setup optionality for fortran, rename USE=pythran (diff)
downloadgentoo-ffbbaca7.tar.gz
gentoo-ffbbaca7.tar.bz2
gentoo-ffbbaca7.zip
dev-python/scipy: drop 1.9.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/scipy/Manifest1
-rw-r--r--dev-python/scipy/scipy-1.9.1.ebuild104
2 files changed, 0 insertions, 105 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index 63506ce1e5bd..663d8b7b9521 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -1,5 +1,4 @@
DIST scipy-1.8.1.tar.gz 38196215 BLAKE2B 180ae646adba2031a4bf99cd4feefe652b8e340110b3b2872e61aa1083054aadf369c7e3b3e3fd8fb71fcd831c95841d2dadd1c71e35e5f7d95800e5551173f0 SHA512 f6fc71c209991fe82baa4b10d8ade0deb1057f6f5942a91dfb7ae45f3eb78a4535efa2861badf5e2d37239fa99dbd99de760aa7e4854b95991ade0263004e7ea
-DIST scipy-1.9.1.tar.gz 42019478 BLAKE2B aa7f9e8f354d2c73cfeb0e349562279ec323e6c16641c82c47080108d21f385acb1431c1f072e454a043f56e8fd708778fc34c0eddaceedca979f40b6b11e358 SHA512 1378a24c59b66e2818929acd015fe5408cdd57926d96b7b909d5eb7e2bb6bae942e8fe802f107c8b0901af9873b8e24461624ca0917867e24bb50c7d28e09e71
DIST scipy-1.9.2.tar.gz 42068300 BLAKE2B 0962115990a12339d8b87eabbee02d52a52e57259fbe2e74884fa2f08d66d8b7505f84561f643b539603bc8bf4ef3bf73c3d908453fbb0c99f732c3a81f8a328 SHA512 5f8667aa66aa0b5fad689d960f742874ce09f830bfd5aa241917526f153fbc09c7f709bc84113f83283fcbb8a47113eb215478d9c3473f76d8f7dbf0989429a2
DIST scipy-1.9.3.tar.gz 42075414 BLAKE2B f19e829d26a5673cccb69bce43a9142637f42a9ec462a3fd2ea44b62564cff6fb27a4deaccc59e0e738cc0c997b0a7de948bf9f2db6fa7896323405a072e0111 SHA512 119f9a5e1ce3b4268ba38a0eb82dff78837593d9a5c5e464663925a4b3b1de060201fe568236e19ed0996a045754333c580e181c4cdec2cc707e57060f59364e
DIST scipy-html-1.8.1.zip 37060661 BLAKE2B 2fa617c58eb47463f8a61f9798b32c6da255d26b8e86c1558e427a715093f5a29ced3847ab6ecfe88ce1017664f36ac3e9fa9bbf72ede7e0fd3812b5f41fe933 SHA512 95153dc1f404aa64898a700c94c0deea3ca842c3152167d0987edabcf4a8eba16b6c8e6bc38a6775a849dc621e6a21434baf53d1669b1865fa5049cffa4387ac
diff --git a/dev-python/scipy/scipy-1.9.1.ebuild b/dev-python/scipy/scipy-1.9.1.ebuild
deleted file mode 100644
index 3968a54a22ab..000000000000
--- a/dev-python/scipy/scipy-1.9.1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit fortran-2 distutils-r1 multiprocessing
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="
- https://scipy.org/
- https://github.com/scipy/scipy/
- https://pypi.org/project/scipy/
-"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
-
- # Need submodules, so git for now.
- EGIT_REPO_URI="https://github.com/scipy/scipy"
- EGIT_BRANCH="maintenance/$(ver_cut 1-2).x"
- EGIT_SUBMODULES=( '*' )
-else
- # Upstream is often behind with doc updates
- DOC_PV=1.8.1
- MY_PV=${PV/_rc/rc}
- MY_P=${PN}-${MY_PV}
-
- SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz
- doc? (
- https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${DOC_PV}.zip
- https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-ref-${DOC_PV}.pdf
- )"
- S="${WORKDIR}"/${MY_P}
-
- if [[ ${PV} != *rc* ]] ; then
- KEYWORDS="~amd64 ~arm64 -hppa ~ppc64 ~riscv"
- fi
-fi
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc"
-
-# umfpack is technically optional but it's preferred to have it available.
-DEPEND="
- >=dev-python/numpy-1.18.5[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack:=
- sci-libs/umfpack
- virtual/cblas
- >=virtual/lapack-3.8
-"
-RDEPEND="
- ${DEPEND}
- dev-python/pillow[${PYTHON_USEDEP}]
-"
-# TODO: restore pythran optionality?
-BDEPEND="
- dev-lang/swig
- >=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- dev-python/pythran[${PYTHON_USEDEP}]
- >=dev-util/meson-0.62.2
- dev-util/patchelf
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.9999-meson-options-lapack.patch
-)
-
-EPYTEST_DESELECT=(
- linalg/tests/test_decomp.py::TestSchur::test_sort
- linalg/tests/test_solvers.py::test_solve_discrete_are
-)
-
-distutils_enable_tests pytest
-
-src_unpack() {
- default
-
- if use doc; then
- unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
- fi
-}
-
-python_test() {
- cd "${T}" || die
-
- epytest -n "$(makeopts_jobs)" --pyargs scipy
-}
-
-python_install_all() {
- use doc && \
- local DOCS=( "${DISTDIR}"/${PN}-ref-${DOC_PV}.pdf ) \
- local HTML_DOCS=( "${WORKDIR}"/html/. )
-
- distutils-r1_python_install_all
-}