summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-10-14 23:16:32 -0400
committerCraig Andrews <candrews@gentoo.org>2021-10-14 23:16:57 -0400
commitffe8b05075e6d8bd7293c41bec413beb96d58300 (patch)
tree15ca92b3e95041eb299b1c077cb4f14f0e5e9836
parentnet-mail/onionrouter: dev-python/pyyaml-6.0 and Python 3.10 support (diff)
downloadgentoo-ffe8b050.tar.gz
gentoo-ffe8b050.tar.bz2
gentoo-ffe8b050.zip
net-mail/onionrouter: Cleanup old version
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-mail/onionrouter/onionrouter-0.6.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/net-mail/onionrouter/onionrouter-0.6.1.ebuild b/net-mail/onionrouter/onionrouter-0.6.1.ebuild
deleted file mode 100644
index 2efd032bc84b..000000000000
--- a/net-mail/onionrouter/onionrouter-0.6.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 systemd
-
-DESCRIPTION=".onion discovery via SRV DNS lookups for use with postfix"
-HOMEPAGE="https://pypi.org/project/onionrouter/ https://github.com/ehloonion/onionrouter/"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/ehloonion/onionrouter.git"
- inherit git-r3
-else
- KEYWORDS="~amd64"
- SRC_URI="https://pypi.io/packages/source/${PN::1}/${PN}/${P}.tar.gz"
-fi
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-RDEPEND="$(python_gen_cond_dep '
- dev-python/dnspython[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-')"
-BDEPEND="$(python_gen_cond_dep '
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-')"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-}
-
-src_install() {
- distutils-r1_src_install
- systemd_dounit "${FILESDIR}/${PN}.service"
- insinto /etc/onionrouter
- doins "${S}/onionrouter/configs/onionrouter.ini"
-}