summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-31 08:39:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-31 08:53:03 +0100
commitfffbe8d5299474be67473b48683a7d5153fb0dcc (patch)
treeb6fa2367034e87e6445d115b0b4a8dbd2d769683
parentdev-python/filelock: Bump to 3.13.1 (diff)
downloadgentoo-fffbe8d5299474be67473b48683a7d5153fb0dcc.tar.gz
gentoo-fffbe8d5299474be67473b48683a7d5153fb0dcc.tar.bz2
gentoo-fffbe8d5299474be67473b48683a7d5153fb0dcc.zip
dev-python/poetry-plugin-export: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/poetry-plugin-export/Manifest1
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.6.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/Manifest b/dev-python/poetry-plugin-export/Manifest
index 9e8d46d5a1d6..0d130641c7eb 100644
--- a/dev-python/poetry-plugin-export/Manifest
+++ b/dev-python/poetry-plugin-export/Manifest
@@ -1,2 +1,3 @@
DIST poetry_plugin_export-1.4.0.tar.gz 28553 BLAKE2B d2f7de4da9975cefde9ac02d9e4a36eada89fe00926eaf58d8ea402d57ef53209aa2e564b46616f0d71fa675512de6335a33a1714efe4a696f05c909a8313e45 SHA512 60fd1a63505e82f62372e7ec4e4908835f0556e86213b58ce836d3cf64bd6de8f83cbc965ad1a2b59c50ca3bf287675bda46b5a410a5f65078e091004eaf8ed9
DIST poetry_plugin_export-1.5.0.tar.gz 28902 BLAKE2B 09dc4e6a30431d3436a50bc773f965617961be70b7dfe91dde37e90ddc7b409e1b7bf318fc42104a870735d6a9ef94e66b3fbf08a23c5f74b07eeeec7d0bea52 SHA512 b8a75e15fe9d13890f058ee3b8e616c24d3914dc69d8bceb6e4288beda0e054061f8ee48e1fd0f2a72973af28ac692b08fb8633ed6706f29386b8a3680947961
+DIST poetry_plugin_export-1.6.0.tar.gz 29265 BLAKE2B 90690afe197fd109d5fc5ae4566675a6a1e5e4df50cd814370146501389ba3bb0e78c2be2878cac322548ea5be065ef68f5b28a6d79a003d0f7b31c149ad0214 SHA512 d071f69ace98dbc23a3b129ba7fb30c4e6eac07138f4ee5156c266150f8f025f8b69c61dfadd90d29e1895c70d448fc44a9b5cc502024f00e1657247ed3310bd
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.6.0.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.6.0.ebuild
new file mode 100644
index 000000000000..e09698cfb060
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.7.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/poetry[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest