summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-27 20:51:38 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-27 20:51:38 +0200
commitb0cf0305314b2410b608e087e0b960e8a1e8369d (patch)
tree2b002fe4190cd4745c4d97e9aadda8b8ecb61202 /acct-user/firebird/firebird-0-r2.ebuild
parentdev-lua/luasocket: add 3.1.0 (diff)
downloadgentoo-b0cf0305314b2410b608e087e0b960e8a1e8369d.tar.gz
gentoo-b0cf0305314b2410b608e087e0b960e8a1e8369d.tar.bz2
gentoo-b0cf0305314b2410b608e087e0b960e8a1e8369d.zip
acct-user/firebird: use correct uid
User has been using incorrectly wrong UID. Closes: https://bugs.gentoo.org/861491 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'acct-user/firebird/firebird-0-r2.ebuild')
-rw-r--r--acct-user/firebird/firebird-0-r2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/acct-user/firebird/firebird-0-r2.ebuild b/acct-user/firebird/firebird-0-r2.ebuild
new file mode 100644
index 000000000000..e34d2c1a8ac7
--- /dev/null
+++ b/acct-user/firebird/firebird-0-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="A user for dev-db/firebird"
+
+ACCT_USER_GROUPS=( "firebird" )
+ACCT_USER_ID="450"
+ACCT_USER_SHELL="/bin/sh"
+
+acct-user_add_deps
+
+pkg_setup() {
+ ACCT_USER_HOME="/usr/$(get_libdir)/firebird"
+}