summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2023-01-27 18:17:27 +0300
committerConrad Kostecki <conikost@gentoo.org>2023-02-01 02:08:24 +0100
commitb5153ffa5ea7fe2fd116ab191c558b5eb4226906 (patch)
tree162da40e4a3f10cd4c4f5d8840be3df3649362de /acct-user/named/named-0-r1.ebuild
parentdev-lua/luaposix: drop 36.0 (diff)
downloadgentoo-b5153ffa5ea7fe2fd116ab191c558b5eb4226906.tar.gz
gentoo-b5153ffa5ea7fe2fd116ab191c558b5eb4226906.tar.bz2
gentoo-b5153ffa5ea7fe2fd116ab191c558b5eb4226906.zip
acct-user/*: remove ACCT_USER_HOME_OWNER if it is equal to default
`acct-user.eclass`'s documentation [says](https://devmanual.gentoo.org/eclass-reference/acct-user.eclass/index.html): ``` ACCT_USER_HOME_OWNER The ownership to use for the home directory, in chown ([user][:group]) syntax. Defaults to the newly created user, and its primary group. ``` ``` ACCT_USER_GROUPS (REQUIRED) List of groups the user should belong to. This must be a bash array. The first group specified is the user's primary group, while the remaining groups (if any) become supplementary groups. ``` So we can remove in `acct-user/user/user-0.ebuild`: ``` ACCT_USER_HOME_OWNER="user" ``` Moreover if we have: ``` ACCT_USER_GROUPS=( primary_group group2 ) ``` , we can remove ``` ACCT_USER_HOME_OWNER="user:primary_group" ``` Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/29214 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'acct-user/named/named-0-r1.ebuild')
-rw-r--r--acct-user/named/named-0-r1.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/acct-user/named/named-0-r1.ebuild b/acct-user/named/named-0-r1.ebuild
index 103b3149f63d..4ca236119be0 100644
--- a/acct-user/named/named-0-r1.ebuild
+++ b/acct-user/named/named-0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,6 @@ DESCRIPTION="User for net-dns/bind"
ACCT_USER_ID=40
ACCT_USER_HOME=/etc/bind
-ACCT_USER_HOME_OWNER=named:named
ACCT_USER_GROUPS=( named )
acct-user_add_deps