summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2022-03-15 12:50:36 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2022-03-15 12:56:13 -0400
commit2f23d054130c5b787d900ed70b2a7f95d3710f06 (patch)
tree94185777327196179d31e9e00509c33202a4a66a /acct-user/pgagent/pgagent-0.ebuild
parentvirtual/perl-Module-CoreList: Add 5.34.1 version (diff)
downloadgentoo-2f23d054130c5b787d900ed70b2a7f95d3710f06.tar.gz
gentoo-2f23d054130c5b787d900ed70b2a7f95d3710f06.tar.bz2
gentoo-2f23d054130c5b787d900ed70b2a7f95d3710f06.zip
acct-user/pgagent: Initial 0 release for GLEP-81 update
Bug: https://bugs.gentoo.org/781284 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'acct-user/pgagent/pgagent-0.ebuild')
-rw-r--r--acct-user/pgagent/pgagent-0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/acct-user/pgagent/pgagent-0.ebuild b/acct-user/pgagent/pgagent-0.ebuild
new file mode 100644
index 000000000000..da03477a46a1
--- /dev/null
+++ b/acct-user/pgagent/pgagent-0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="pgagent program user"
+ACCT_USER_ID=135
+ACCT_USER_SHELL=/bin/bash
+ACCT_USER_HOME=/var/lib/pgagent
+ACCT_USER_GROUPS=( pgagent )
+acct-user_add_deps
+SLOT="0"
+
+pkg_postinst() {
+ ewarn "The home directory has changed for pgagent."
+ ewarn "You should move files, especially .pgpass, from:"
+ ewarn " /home/pgagent"
+ ewarn "To:"
+ ewarn " ${ACCT_USER_HOME}"
+}