summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-19 16:21:59 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-19 16:24:13 -0600
commit997240bca001d96500c3504c1da0a1b0089ffaab (patch)
tree984dd1aff675196216290d69bda70bfcfa5963f5 /acct-user/puppet/puppet-0.ebuild
parentacct-group/puppetdb: add puppetdb group (diff)
downloadgentoo-997240bca001d96500c3504c1da0a1b0089ffaab.tar.gz
gentoo-997240bca001d96500c3504c1da0a1b0089ffaab.tar.bz2
gentoo-997240bca001d96500c3504c1da0a1b0089ffaab.zip
acct-user/puppet: add puppet user
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'acct-user/puppet/puppet-0.ebuild')
-rw-r--r--acct-user/puppet/puppet-0.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/acct-user/puppet/puppet-0.ebuild b/acct-user/puppet/puppet-0.ebuild
new file mode 100644
index 000000000000..61230a8a6a60
--- /dev/null
+++ b/acct-user/puppet/puppet-0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="user for puppet services"
+ACCT_USER_ID=455
+ACCT_USER_HOME=/var/lib/puppet
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( puppet )
+
+acct-user_add_deps