summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-04 11:24:38 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-04 11:25:12 +0100
commit9972fed3f21b47e7315949e39f762d9b209c1fd5 (patch)
tree4c1b270f881f9f18b6680877688a8ac0e688517a /app-accessibility/brltty
parentmedia-sound/jack2: require any of classic and dbus (diff)
downloadgentoo-9972fed3f21b47e7315949e39f762d9b209c1fd5.tar.gz
gentoo-9972fed3f21b47e7315949e39f762d9b209c1fd5.tar.bz2
gentoo-9972fed3f21b47e7315949e39f762d9b209c1fd5.zip
app-accessibility/brltty: [QA] Fix multiple issues
* Don't add dead python impls to PYTHON_COMPAT * Don't remove python metadata vars (${PYTHON_REQUIRED_USE}) from REQUIRED_USE * Don't remove the SLOT specifier for sys-libs/ncurses * Get rid of the awfully complicated, hacky and non-generalisable solution for the libtinfo split, which also doesn't generalise to Prefix. Using pkg-config is easier, safer, more portable and less brittle than the previous hacks. * Get rid of the totally unnecessary code paths created by dispatching on glibc versions. 'sys/sysmacros.h' can always be included on glibc, packages just have relied on this include implicitly. Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-accessibility/brltty')
-rw-r--r--app-accessibility/brltty/brltty-5.2-r1.ebuild12
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-sysmacros.patch20
2 files changed, 13 insertions, 19 deletions
diff --git a/app-accessibility/brltty/brltty-5.2-r1.ebuild b/app-accessibility/brltty/brltty-5.2-r1.ebuild
index 12ea62ef94e3..71cbc57d9d13 100644
--- a/app-accessibility/brltty/brltty-5.2-r1.ebuild
+++ b/app-accessibility/brltty/brltty-5.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
FINDLIB_USE="ocaml"
inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic \
@@ -22,7 +22,7 @@ IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
REQUIRED_USE="doc? ( api )
java? ( api )
ocaml? ( api )
- python? ( api )
+ python? ( api ${PYTHON_REQUIRED_USE} )
tcl? ( api )"
COMMON_DEP="bluetooth? ( net-wireless/bluez )
@@ -30,7 +30,7 @@ COMMON_DEP="bluetooth? ( net-wireless/bluez )
iconv? ( virtual/libiconv )
icu? ( dev-libs/icu:= )
python? ( ${PYTHON_DEPS} )
- ncurses? ( sys-libs/ncurses:= )
+ ncurses? ( sys-libs/ncurses:0= )
nls? ( virtual/libintl )
tcl? ( >=dev-lang/tcl-8.4.15:0= )
usb? ( virtual/libusb:0 )
@@ -64,10 +64,8 @@ src_prepare() {
}
src_configure() {
- filter-flags "_*_SOURCE*"
- append-cppflags -D_DEFAULT_SOURCE
- has_version ">=sys-libs/glibc-2.25-r5" && append-cppflags -DHAVE_SYS_SYSMACROS_H
- has_version "sys-libs/ncurses[tinfo]" && append-libs -ltinfo
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags ncurses)"
+ append-libs "$($(tc-getPKG_CONFIG) --libs ncurses)"
tc-export AR LD PKG_CONFIG
# override prefix in order to install into /
diff --git a/app-accessibility/brltty/files/brltty-5.2-sysmacros.patch b/app-accessibility/brltty/files/brltty-5.2-sysmacros.patch
index d45d6104e4bb..f33e46a1890c 100644
--- a/app-accessibility/brltty/files/brltty-5.2-sysmacros.patch
+++ b/app-accessibility/brltty/files/brltty-5.2-sysmacros.patch
@@ -1,24 +1,20 @@
---- a/Programs/system_linux.c 2017-12-02 12:54:34.098643832 -0800
-+++ b/Programs/system_linux.c 2017-12-02 12:59:00.683592161 -0800
-@@ -24,6 +24,9 @@
+--- a/Programs/system_linux.c
++++ b/Programs/system_linux.c
+@@ -24,6 +24,7 @@
#include <fcntl.h>
#include <sys/ioctl.h>
#include <sys/stat.h>
-+#ifdef HAVE_SYS_SYSMACROS_H
-+#include <sys/sysmacros.h> /* major() w/newer glibc */
-+#endif
++#include <sys/sysmacros.h>
#include "log.h"
#include "file.h"
---- a/Programs/brlapi_client.c 2017-12-02 14:29:37.524205316 -0800
-+++ b/Programs/brlapi_client.c 2017-12-02 14:32:45.679948051 -0800
-@@ -73,6 +73,9 @@
+--- a/Programs/brlapi_client.c
++++ b/Programs/brlapi_client.c
+@@ -73,6 +73,7 @@
#include <linux/tty.h>
#include <linux/vt.h>
#define MAXIMUM_VIRTUAL_CONSOLE MAX_NR_CONSOLES
-+#ifdef HAVE_SYS_SYSMACROS_H
-+#include <sys/sysmacros.h> /* major() w/newer glibc */
-+#endif
++#include <sys/sysmacros.h>
#endif /* linux */
#ifdef __OpenBSD__