summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-06 22:57:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-07 10:56:37 +0200
commit122aa10e01900d77374086188637d04f71927b8c (patch)
tree6f0329520690a2c1354f969bcb668f13c356480b /app-accessibility/kontrast/kontrast-1.0.2.ebuild
parentx11-wm/enlightenment: Inherit optfeature.eclass (diff)
downloadgentoo-122aa10e01900d77374086188637d04f71927b8c.tar.gz
gentoo-122aa10e01900d77374086188637d04f71927b8c.tar.bz2
gentoo-122aa10e01900d77374086188637d04f71927b8c.zip
app-accessibility/kontrast: 1.0.2 version bump
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-accessibility/kontrast/kontrast-1.0.2.ebuild')
-rw-r--r--app-accessibility/kontrast/kontrast-1.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-accessibility/kontrast/kontrast-1.0.2.ebuild b/app-accessibility/kontrast/kontrast-1.0.2.ebuild
new file mode 100644
index 000000000000..45ffbbb518bf
--- /dev/null
+++ b/app-accessibility/kontrast/kontrast-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.70.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Tool to check contrast for colors to verify they are correctly accessible"
+HOMEPAGE="https://invent.kde.org/accessibility/kontrast"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="5"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"