summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/sphinxbase/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/sphinxbase/files')
-rw-r--r--app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch25
-rw-r--r--app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch85
2 files changed, 110 insertions, 0 deletions
diff --git a/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch b/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch
new file mode 100644
index 000000000000..11031918ee68
--- /dev/null
+++ b/app-accessibility/sphinxbase/files/sphinxbase-0.8-automake113.patch
@@ -0,0 +1,25 @@
+diff -Naur sphinxbase-0.8/test/regression/Makefile.am sphinxbase-0.8.new/test/regression/Makefile.am
+--- sphinxbase-0.8/test/regression/Makefile.am 2012-12-05 06:05:39.000000000 -0800
++++ sphinxbase-0.8.new/test/regression/Makefile.am 2013-10-08 13:05:15.498853962 -0700
+@@ -33,9 +33,19 @@
+
+ # Disable sphinx_fe tests for now if fixed-point due to imprecision
+ if FIXED_POINT
+-TESTS = $(srcdir)/test-cepview.sh $(srcdir)/test-sphinx_pitch.sh
++TESTS = test-cepview.sh test-sphinx_pitch.sh
+ else
+-TESTS = $(srcdir)/test-*.sh
++TESTS = \
++ test-cepview.sh \
++ test-sphinx_fe-ctl.sh \
++ test-sphinx_fe-dct.sh \
++ test-sphinx_fe-dither-seed.sh \
++ test-sphinx_fe-logspec2cep.sh \
++ test-sphinx_fe-logspec.sh \
++ test-sphinx_fe.sh \
++ test-sphinx_fe-smoothspec.sh \
++ test-sphinx_jsgf2fsg.sh \
++ test-sphinx_pitch.sh
+ endif
+
+ EXTRA_DIST += $(TESTS)
diff --git a/app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch b/app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch
new file mode 100644
index 000000000000..70beae05de7e
--- /dev/null
+++ b/app-accessibility/sphinxbase/files/sphinxbase-0.8-unbundle-lapack.patch
@@ -0,0 +1,85 @@
+ configure.in | 40 +++++++++++++++++++++-------------------
+ src/libsphinxbase/Makefile.am | 1 +
+ 2 files changed, 22 insertions(+), 19 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index e10629c..b5d6ea9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -62,13 +62,15 @@ if test x$withval = xno; then
+ use_lapack=false
+ fi
+ ])
+-if test x$use_lapack = xtrue; then
+- AC_CHECK_LIB(lapack, sgesv_,,use_internal_lapack=true)
+- if test x$use_internal_lapack != xtrue; then
+- AC_CHECK_LIB(blas, sgemm_,,use_internal_lapack=true)
+- fi
++AS_IF([test "x$with_lapack" = "xyes"], [
++ PKG_CHECK_MODULES([LAPACK], [lapack],,
++ AC_CHECK_LIB(lapack, sgesv_,,use_internal_lapack=true))
++ AS_IF([test "x$use_internal_lapack" != "xtrue"], [
++ PKG_CHECK_MODULES([BLAS], [blas],,
++ AC_CHECK_LIB(blas, sgemm_,,use_internal_lapack=true))
++ ])
+ AC_DEFINE(WITH_LAPACK, [], [Enable matrix algebra with LAPACK])
+-fi
++])
+ AM_CONDITIONAL(LAPACK_LITE, test x$use_internal_lapack = xtrue)
+ AM_CONDITIONAL(USE_LAPACK, test x$use_lapack = xtrue)
+
+@@ -208,9 +210,15 @@ AM_PROG_LIBTOOL
+ dnl
+ dnl Check for Doxygen, and build dox if present
+ dnl
+-AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, yes, no)
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--enable-doc], [Build docs using doxygen]))
++AS_IF([test "x$enable_doc" = "xyes"], [
++ AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, yes, no)
++ AS_IF([test "x$HAVE_DOXYGEN" != "xyes"], [
++ AC_MSG_ERROR([--enable-doc given, but doxygen not found.]); exit 1
++ ])
++])
+ AM_CONDITIONAL(BUILD_DOXYGEN, test "x$HAVE_DOXYGEN" = "xyes")
+-
+ dnl
+ dnl Check for Python, and build python module if present
+ dnl
+@@ -260,19 +268,13 @@ fi
+ AM_CONDITIONAL(BUILD_CYTHON, test "x$HAVE_CYTHON" = "xyes")
+
+ dnl
+-dnl Check for pkgconfig
+-dnl
+-AC_CHECK_PROG(HAVE_PKGCONFIG, pkg-config, yes, no)
+-
+-dnl
+ dnl Check for libsndfile
+ dnl
+-if test "x$HAVE_PKGCONFIG" = "xyes"; then
+- PKG_CHECK_MODULES(SNDFILE,sndfile,,true)
+- AC_CHECK_HEADERS([sndfile.h])
+- PKG_CHECK_MODULES(SAMPLERATE,samplerate,,true)
+- AC_CHECK_HEADERS([samplerate.h])
+-fi
++PKG_CHECK_MODULES(SNDFILE,sndfile,,true)
++AC_CHECK_HEADERS([sndfile.h])
++PKG_CHECK_MODULES(SAMPLERATE,samplerate,,true)
++AC_CHECK_HEADERS([samplerate.h])
++
+ AC_SUBST(SNDFILE_LIBS)
+ AC_SUBST(SNDFILE_CFLAGS)
+ AC_SUBST(SAMPLERATE_LIBS)
+diff --git a/src/libsphinxbase/Makefile.am b/src/libsphinxbase/Makefile.am
+index 52ee3e1..f4efd8a 100644
+--- a/src/libsphinxbase/Makefile.am
++++ b/src/libsphinxbase/Makefile.am
+@@ -8,6 +8,7 @@ libsphinxbase_la_SOURCES =
+ # This is API version 2, software release 1, which also supports API version 1
+ libsphinxbase_la_LDFLAGS = -version-info 2:1:1
+ libsphinxbase_la_LIBADD = $(LTLIBICONV) \
++ @LAPACK_LIBS@ \
+ util/libsphinxutil.la \
+ fe/libsphinxfe.la \
+ feat/libsphinxfeat.la \