summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-15 13:12:15 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-15 13:33:04 +0100
commit36062e12c363790c60432af67b3a017e54e4bfff (patch)
tree41172a3c33c7a645bd0706c8059c93a218543e94 /app-admin/ansible-base
parentdev-util/cmake: Removed old (diff)
downloadgentoo-36062e12c363790c60432af67b3a017e54e4bfff.tar.gz
gentoo-36062e12c363790c60432af67b3a017e54e4bfff.tar.bz2
gentoo-36062e12c363790c60432af67b3a017e54e4bfff.zip
app-admin/ansible: move the live ebuild to ansible-base
This is what the upstream GitHub repo has been since the introduction of collections (which have their own, separate repos in the organisation "ansible-collections"). Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin/ansible-base')
-rw-r--r--app-admin/ansible-base/ansible-base-9999.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/ansible-base/ansible-base-9999.ebuild b/app-admin/ansible-base/ansible-base-9999.ebuild
new file mode 100644
index 000000000000..466c8bf7fc59
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ MY_PN="${PN/-base/-core}"
+ MY_P="${MY_PN}-${PV}"
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/resolvelib[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}