summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-12-07 11:12:41 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-12-07 11:39:05 -0600
commita3f02bea781f135a7174b60646182840d217d2dd (patch)
tree3ff9da3fc05c60a6b9bc4c47bdc5517249fc8ff5 /app-admin/ansible-base
parentwww-client/chromium: stable channel bump to 96.0.4664.93 (diff)
downloadgentoo-a3f02bea781f135a7174b60646182840d217d2dd.tar.gz
gentoo-a3f02bea781f135a7174b60646182840d217d2dd.tar.bz2
gentoo-a3f02bea781f135a7174b60646182840d217d2dd.zip
app-admin/ansible-base: 2.11.7 and 2.12.1 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible-base')
-rw-r--r--app-admin/ansible-base/Manifest2
-rw-r--r--app-admin/ansible-base/ansible-base-2.11.7.ebuild64
-rw-r--r--app-admin/ansible-base/ansible-base-2.12.1.ebuild64
-rw-r--r--app-admin/ansible-base/ansible-base-9999.ebuild4
4 files changed, 132 insertions, 2 deletions
diff --git a/app-admin/ansible-base/Manifest b/app-admin/ansible-base/Manifest
index 5f9f8d10cdf6..70f3a77466c9 100644
--- a/app-admin/ansible-base/Manifest
+++ b/app-admin/ansible-base/Manifest
@@ -3,4 +3,6 @@ DIST ansible-core-2.11.3.tar.gz 6841255 BLAKE2B fde1143515d04121de79ddb2c14bf326
DIST ansible-core-2.11.4.tar.gz 6843603 BLAKE2B fa8e72a9e77633b1b43a9a290d92db009e95ed87357f666059ed7898031f584c993ebeb6acec8cad29376666f3a714a742f4e52ac8f2baaf5d01c02796b64acd SHA512 9385a3877e6e9a25d244c855cf50c0c6b62a91cc9cebc5e7b5b5ec23424b3e3dcddd71e7367482a03996fcd5d591ad29771edd19d62758ae61473f97a5c9351d
DIST ansible-core-2.11.5.tar.gz 6847600 BLAKE2B 83a80dcfda427b5d41eb3288d6b60cf710124a82edce2817a6bd5bbed0dc0157fed444b45db6428640dd25164306c987af9aba6f87ef52c63229ae113754b7c3 SHA512 73cfdb65e984856b84a0f7d0e1164a97ddbcdc38e00479f15c4a335297ba3a8f43dc503dc5b4a3f1fea06f91a3c4590b66dd680adb95b765c034207a8de5d589
DIST ansible-core-2.11.6.tar.gz 6999232 BLAKE2B 5105928881297226e982e42c8027a370ad31869d92ca87d338cdb6e72504a22cf3fe7843921905599c7126c840197fb7799a72c261a007437a437b85c4a65c68 SHA512 d14686afb7b2802be3bca3baf6f3840d33f7994b7c48fcb4d42f871e13e4eb54ffef413e124dbe614a55041c23b509f5e887b687dbb6c4868425957cac45910a
+DIST ansible-core-2.11.7.tar.gz 7108269 BLAKE2B c5080161bfffc34382db86f3940dbbf1c8194a4413b20ef28b3c15503aec905acfffc864041496b4f6b4b77966fee3221b80e90d4b952e38513ba9ce506ee1ae SHA512 f37c925c5302eff30d17f52a04d4a5311e38ee5c1d6db4fbdb32970afa362e0522d6ec3d07bddf40137b2f5ec5fa03a2b72e7e1ed313c28c207f65490e49af92
DIST ansible-core-2.12.0.tar.gz 7405927 BLAKE2B 9256d88910bf13dfac87ba509f0b1478305f9a07d8f935479b1a23ea1b9b3e8daf33030aee8ea3f9251cc858ab04bcf189f9226323157a1a2ae1fbcf5c4fb0a1 SHA512 c3c8c0e2f14c30cecb6e693fc57d2bd686221efaf42f09773bd4606031e4fed68a216be17c040d51601f2059d0f4a44568cea309c3bd2a1c02957c6a4cd6d25a
+DIST ansible-core-2.12.1.tar.gz 7401160 BLAKE2B 2bc412bade7f7e5dee0e51c78a74b4dea286aca1b82e2217012f168cd529a06887f11d672ff883af6a71c3af6ea1596f6720bcde9ed3696f87b8b5def1a1172b SHA512 89468d172dca502da42b94d0a781906578322ac531b3dfc3cece383b0e93fbec0f199d7b76abfd80d24654d5d939ee66a15b74565f50cca0c72d427aab9f4e08
diff --git a/app-admin/ansible-base/ansible-base-2.11.7.ebuild b/app-admin/ansible-base/ansible-base-2.11.7.ebuild
new file mode 100644
index 000000000000..d343cc2ca2d2
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-2.11.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ MY_PN="${PN/-base/-core}"
+ MY_P="${MY_PN}-${PV}"
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-0.6.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
diff --git a/app-admin/ansible-base/ansible-base-2.12.1.ebuild b/app-admin/ansible-base/ansible-base-2.12.1.ebuild
new file mode 100644
index 000000000000..caee1ffe1113
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-2.12.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ MY_PN="${PN/-base/-core}"
+ MY_P="${MY_PN}-${PV}"
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-0.6.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
diff --git a/app-admin/ansible-base/ansible-base-9999.ebuild b/app-admin/ansible-base/ansible-base-9999.ebuild
index 957f728b3909..caee1ffe1113 100644
--- a/app-admin/ansible-base/ansible-base-9999.ebuild
+++ b/app-admin/ansible-base/ansible-base-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1