summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-19 00:16:44 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-19 00:18:42 +0100
commit7e35bca138fd214107bfbeea344c8616bed6d912 (patch)
treed5cd3d3c1fa6bfb97e224a349a45b44adfee845b /app-admin/ansible-lint
parentx11-libs/gtk+: Version bump to 3.24.34 (diff)
downloadgentoo-7e35bca138fd214107bfbeea344c8616bed6d912.tar.gz
gentoo-7e35bca138fd214107bfbeea344c8616bed6d912.tar.bz2
gentoo-7e35bca138fd214107bfbeea344c8616bed6d912.zip
app-admin/ansible-lint: add 6.1.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.1.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 5f77818c06af..9337e75978ed 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,2 +1,3 @@
DIST ansible-lint-5.4.0.tar.gz 349353 BLAKE2B 9f41abdf1e9485afa4c8ed9498627b0dcbdcf57916f3b57c9886de8bd806e4e5b34e7e9c2e66b44ac8009a0afcea4d8566900ee8d391eaca61081fa23323c41c SHA512 f1bbbb49eb77991d60b6087646c695a938d328d719bba67707af4ed858de857d383b78490bcf0930cffebd13a0b0abde20269a47e47e4713a37da715a28c5da0
DIST ansible-lint-6.0.2.tar.gz 195044 BLAKE2B 3334049dd1dc05444c6c362601da8d7e808c6b3473e87613b8892651cecb76058cb0aa370aa5d00cf6bc76ee3b096480fdce52facee4f043c01d6c76084860ba SHA512 a47e79c59dfcf3e36654247bd206581798f2559261142e3943b60e0688d75b5a6332832a9f9127f99b2faa6afff959a33c55fbc80aa5881f064725998420f679
+DIST ansible-lint-6.1.0.tar.gz 223702 BLAKE2B 5aeaccbaf9c1bd8e7236e946b408779b42e0839766a485bdbb80ece19ed63b57fa38cb44796c860f6929bb2e98acd21a3de3a9c07486535ed3e6ab5cb499c8d9 SHA512 c1ca5abe8e5f441a86db6a4b4fa03c2d87ed2277151ada9af34c3d8af6934d2c1d4b6bffbc11d6cfb7cd7601c9e43a041fe8a2b940fa0630532df05004e11d15
diff --git a/app-admin/ansible-lint/ansible-lint-6.1.0.ebuild b/app-admin/ansible-lint/ansible-lint-6.1.0.ebuild
new file mode 100644
index 000000000000..994f48b51065
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-6.1.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+# PyPI tarballs do not contain all the data files needed by the tests
+SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Since 6.0.2, access to Ansible Galaxy (i.e. the Internet) is required even to get
+# the test suite started (Bug #836582). TODO: Talk to upstream about how to bypass this.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-2.0.3[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.5.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
+)
+
+# Skip problematic tests:
+# - test_call_from_outside_venv doesn't play nicely with the sandbox
+# - all test_eco and some test_prerun tests require Internet access
+# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
+EPYTEST_DESELECT=(
+ test/test_eco.py
+ test/test_main.py::test_call_from_outside_venv
+ test/test_prerun.py::test_install_collection
+ test/test_prerun.py::test_prerun_reqs_v1
+ test/test_prerun.py::test_prerun_reqs_v2
+ test/test_prerun.py::test_require_collection_wrong_version
+ test/test_utils.py::test_cli_auto_detect
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ # For some reason the schema files do not get installed in spite of being present in release tarballs,
+ # with the test suite relying on "refreshing" them (i.e. downloading them from the Internet) instead
+ # - and seemingly occasionally failing to do even that right. Just stick with the bundled files.
+ # TODO: check if this is still needed every new release.
+ local schemadir="${BUILD_DIR}/install/$(python_get_sitedir)/ansiblelint/schemas/"
+ cp src/ansiblelint/schemas/*.json "${schemadir}" || die
+
+ epytest test
+
+ # Make sure src_install() does not install these regardless of whether src_test() has run or not.
+ rm "${schemadir}"/*.json || die
+}