summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-17 10:43:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-17 10:43:47 -0500
commit3d68ae0334b10d42f6bc78ef5190bd71ad5c5ebc (patch)
tree72a1c8d4ccdd43deb5521442cb67074c63da46d3 /app-admin/ansible/ansible-2.9.7.ebuild
parentnet-libs/mbedtls: remove vulnerable versions, bug #714582 (diff)
downloadgentoo-3d68ae0334b10d42f6bc78ef5190bd71ad5c5ebc.tar.gz
gentoo-3d68ae0334b10d42f6bc78ef5190bd71ad5c5ebc.tar.bz2
gentoo-3d68ae0334b10d42f6bc78ef5190bd71ad5c5ebc.zip
app-admin/ansible: 2.9.7 bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-2.9.7.ebuild')
-rw-r--r--app-admin/ansible/ansible-2.9.7.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-2.9.7.ebuild b/app-admin/ansible/ansible-2.9.7.ebuild
new file mode 100644
index 000000000000..8c8b3a948043
--- /dev/null
+++ b/app-admin/ansible/ansible-2.9.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}