summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-12-12 13:20:17 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-12-12 13:20:17 -0600
commit17a2448d245f7af9f62f16a72f0794d0f1c1c4c6 (patch)
tree8a55ed1f9590b7ea1b9a3c51253cc8dbdd1b2edb /app-admin/ansible/ansible-8.7.0.ebuild
parentapp-admin/ansible-core: add 2.16.2 (diff)
downloadgentoo-17a2448d245f7af9f62f16a72f0794d0f1c1c4c6.tar.gz
gentoo-17a2448d245f7af9f62f16a72f0794d0f1c1c4c6.tar.bz2
gentoo-17a2448d245f7af9f62f16a72f0794d0f1c1c4c6.zip
app-admin/ansible: add 8.7.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-8.7.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-8.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-8.7.0.ebuild b/app-admin/ansible/ansible-8.7.0.ebuild
new file mode 100644
index 000000000000..05eb18736a9c
--- /dev/null
+++ b/app-admin/ansible/ansible-8.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.15.0
+ <app-admin/ansible-core-2.16"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}