summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-05-23 00:34:20 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-23 00:34:49 +0200
commit9730b699a2d2030ca21df76b0917eec71b4b3604 (patch)
tree915d06f588bce0955367de0ef7cbe56b78be0abd /app-admin/ansible/ansible-9999.ebuild
parentsci-visualization/paraview: version bump to 5.5.0 (diff)
downloadgentoo-9730b699a2d2030ca21df76b0917eec71b4b3604.tar.gz
gentoo-9730b699a2d2030ca21df76b0917eec71b4b3604.tar.bz2
gentoo-9730b699a2d2030ca21df76b0917eec71b4b3604.zip
app-admin/ansible: generate and install documentation using sphinx.
Documentation generation and installation is now available when enabling the doc USE flag. Sphinx will generate the exact same website as the one available on http://docs.ansible.com. As to the manual pages installation, they are already installed automatically. Closes: https://bugs.gentoo.org/652376 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-admin/ansible/ansible-9999.ebuild')
-rw-r--r--app-admin/ansible/ansible-9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index cbb8b3767281..0ca97a267cc6 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -15,7 +15,7 @@ EGIT_BRANCH="devel"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="doc test"
RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
@@ -32,6 +32,7 @@ RDEPEND="
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
@@ -42,6 +43,14 @@ DEPEND="
dev-vcs/git
)"
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
python_prepare_all() {
rm -fv MANIFEST.in || die
distutils-r1_python_prepare_all
@@ -51,11 +60,8 @@ python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}
-python_compile_all() {
- emake -j1 docs
-}
-
python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
distutils-r1_python_install_all
doman docs/man/man1/*.1