summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-03-26 11:19:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-03-26 11:19:24 +0200
commita5357cd65f35ed983d0f00d3cee198016528ef8a (patch)
tree68f653e70a059f153b260f3a5a5f20410338a4d2 /app-admin/apache-tools/apache-tools-2.2.34.ebuild
parentwww-servers/apache: Bye bye apache-2.2 (diff)
downloadgentoo-a5357cd65f35ed983d0f00d3cee198016528ef8a.tar.gz
gentoo-a5357cd65f35ed983d0f00d3cee198016528ef8a.tar.bz2
gentoo-a5357cd65f35ed983d0f00d3cee198016528ef8a.zip
app-admin/apache-tools: Removed depreacated 2.2 version.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-admin/apache-tools/apache-tools-2.2.34.ebuild')
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.34.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/app-admin/apache-tools/apache-tools-2.2.34.ebuild b/app-admin/apache-tools/apache-tools-2.2.34.ebuild
deleted file mode 100644
index e7272e344834..000000000000
--- a/app-admin/apache-tools/apache-tools-2.2.34.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic eutils
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="https://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="ssl"
-RESTRICT="test"
-
-RDEPEND="=dev-libs/apr-1*
- =dev-libs/apr-util-1*
- dev-libs/expat
- dev-libs/libpcre
- kernel_linux? ( sys-apps/util-linux )
- ssl? ( dev-libs/openssl:0= )
- !<www-servers/apache-2.2.4"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.20-Makefile.patch"
-)
-
-src_configure() {
- # Brain dead check.
- tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- append-ldflags $(no-as-needed)
-
- # econf overwrites the stuff from config.layout.
- econf \
- --sbindir=/usr/sbin \
- --with-z=/usr \
- --with-apr=/usr \
- --with-apr-util=/usr \
- --with-pcre=/usr \
- $(use_enable ssl) \
- $(usex ssl '--with-ssl=/usr' '')
-}
-
-src_compile() {
- cd support || die
- emake
-}
-
-src_install () {
- cd support || die
-
- make DESTDIR="${D}" install || die
-
- # install manpages
- doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
- "${S}"/docs/man/{htcacheclean,rotatelogs,ab,logresolve}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
- pushd "${D}"/usr/sbin/ >/dev/null || die
- for i in *; do
- dosym /usr/sbin/${i} /usr/sbin/${i}2
- done
- popd >/dev/null || die
-
- # Provide a symlink for ab-ssl
- if use ssl; then
- dosym /usr/sbin/ab /usr/sbin/ab-ssl
- dosym /usr/sbin/ab /usr/sbin/ab2-ssl
- fi
-
- # make htpasswd accessible for non-root users
- dosym /usr/sbin/htpasswd /usr/bin/htpasswd
- dosym /usr/sbin/htdigest /usr/bin/htdigest
-
- dodoc "${S}"/CHANGES
-}