summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2020-09-30 18:16:32 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2020-09-30 18:21:26 +0300
commitaa72164a2295449bbe4728884441a79d21aa975d (patch)
tree3467a65f01ecce69b1c15eb475b2006a7de2c24b /app-admin/apg/apg-2.3.0b_p20150129.ebuild
parentnet-irc/ptlink-ircd: remove last-rited package (diff)
downloadgentoo-aa72164a2295449bbe4728884441a79d21aa975d.tar.gz
gentoo-aa72164a2295449bbe4728884441a79d21aa975d.tar.bz2
gentoo-aa72164a2295449bbe4728884441a79d21aa975d.zip
app-admin/apg: version bump
- switch to new upstream - update to the latest git head - port cracklib support to the new build system Closes: https://bugs.gentoo.org/629272 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'app-admin/apg/apg-2.3.0b_p20150129.ebuild')
-rw-r--r--app-admin/apg/apg-2.3.0b_p20150129.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/apg/apg-2.3.0b_p20150129.ebuild b/app-admin/apg/apg-2.3.0b_p20150129.ebuild
new file mode 100644
index 000000000000..0d351d723be8
--- /dev/null
+++ b/app-admin/apg/apg-2.3.0b_p20150129.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+BASEVER=$(ver_cut 1-4)
+
+DESCRIPTION="Another Password Generator"
+HOMEPAGE="https://github.com/wilx/apg"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cracklib"
+
+DEPEND="cracklib? ( sys-libs/cracklib )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-${BASEVER}-crypt_password.patch"
+ "${FILESDIR}/${P}-cracklib.patch"
+)
+
+DOCS=( CHANGES README THANKS TODO doc/APG_TIPS doc/rfc0972.txt doc/rfc1750.txt )
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with cracklib)
+}
+
+src_install() {
+ default
+ doman doc/man/apg*
+}