summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/apg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/apg')
-rw-r--r--app-admin/apg/Manifest1
-rw-r--r--app-admin/apg/apg-2.3.0b-r5.ebuild52
-rw-r--r--app-admin/apg/files/apg-2.3.0b-cracklib.patch17
-rw-r--r--app-admin/apg/files/apg-2.3.0b-crypt_password.patch31
-rw-r--r--app-admin/apg/files/apg-glibc-2.4.patch11
-rw-r--r--app-admin/apg/metadata.xml11
6 files changed, 123 insertions, 0 deletions
diff --git a/app-admin/apg/Manifest b/app-admin/apg/Manifest
new file mode 100644
index 000000000000..c673d949fc64
--- /dev/null
+++ b/app-admin/apg/Manifest
@@ -0,0 +1 @@
+DIST apg-2.3.0b.tar.gz 109995 SHA256 d1e52029709e2d7f9cb99bedce3e02ee7a63cff7b8e2b4c2bc55b3dc03c28b92 SHA512 3112d2267f2311f960a52fa268b55a5faf0250a4a8c5e7444f0c1326afa2844a476a54befcf79e5b8532d74c53f6f58ffc420591c8c36798dd82b43c14869e1a WHIRLPOOL 519b9b9137db3e3009d91ca9ab0b0e782c4840aae7b32b3aed035aebdb9380091b82169c9c6bd37829464792dc686219b70403c88b029b713278e7bea7f105d8
diff --git a/app-admin/apg/apg-2.3.0b-r5.ebuild b/app-admin/apg/apg-2.3.0b-r5.ebuild
new file mode 100644
index 000000000000..07375890cbde
--- /dev/null
+++ b/app-admin/apg/apg-2.3.0b-r5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Another Password Generator"
+HOMEPAGE="http://www.adel.nursat.kz/apg/"
+SRC_URI="http://www.adel.nursat.kz/apg/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ppc ~ppc64 x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cracklib"
+
+DEPEND="cracklib? ( sys-libs/cracklib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ chmod -R 0700 "${S}"
+ if use cracklib; then
+ epatch "${FILESDIR}"/${P}-cracklib.patch
+ epatch "${FILESDIR}"/${PN}-glibc-2.4.patch
+ fi
+ epatch "${FILESDIR}"/${P}-crypt_password.patch
+}
+
+src_compile() {
+ sed -i 's,^#\(APG_CS_CLIBS += -lnsl\)$,\1,' Makefile \
+ || die "Sed failed"
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i 's,^APG_CLIBS += -lcrypt,APG_CLIBS += ,' Makefile \
+ || die "Sed failed"
+ fi
+
+ emake \
+ FLAGS="${CFLAGS} ${LDFLAGS}" CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ standalone || die "compile problem"
+ emake FLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ -C bfconvert || die "compile problem"
+}
+
+src_install() {
+ dobin apg apgbfm bfconvert/bfconvert || die
+ dodoc CHANGES INSTALL README THANKS TODO || die
+ cd doc
+ doman man/apg.1 man/apgbfm.1 || die
+ dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt || die
+}
diff --git a/app-admin/apg/files/apg-2.3.0b-cracklib.patch b/app-admin/apg/files/apg-2.3.0b-cracklib.patch
new file mode 100644
index 000000000000..a1c34a14f5a0
--- /dev/null
+++ b/app-admin/apg/files/apg-2.3.0b-cracklib.patch
@@ -0,0 +1,17 @@
+--- Makefile 2003-08-07 09:40:39.000000000 -0600
++++ Makefile.cracklib 2004-10-14 07:16:17.288530686 -0600
+@@ -44,10 +44,10 @@
+ # If you want to use cracklib for password quality check then you
+ # must uncomment the folowing 4 lines (you must not do this for WIN32)
+ #
+-#CRACKLIB_DICTPATH = "/usr/local/lib/pw_dict"
+-#STANDALONE_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I/usr/local/include -L/usr/local/lib
+-#CLISERV_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I/usr/local/include -L/usr/local/lib
+-#APG_CLIBS += -lcrack
++CRACKLIB_DICTPATH = "/usr/lib/cracklib_dict"
++STANDALONE_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}'
++CLISERV_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}'
++APG_CLIBS += -lcrack
+
+ ##################################################################
+ # Support for ANSI X9.17/SHA1 PRNG
diff --git a/app-admin/apg/files/apg-2.3.0b-crypt_password.patch b/app-admin/apg/files/apg-2.3.0b-crypt_password.patch
new file mode 100644
index 000000000000..93f3f152a2b4
--- /dev/null
+++ b/app-admin/apg/files/apg-2.3.0b-crypt_password.patch
@@ -0,0 +1,31 @@
+--- restrict.c 2007-03-09 13:48:27.000000000 +0300
++++ restrict.c 2007-03-09 13:49:31.000000000 +0300
+@@ -33,6 +33,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#if defined(APG_USE_CRACKLIB)
++#include <crack.h>
++#endif /* APG_USE_CRACKLIB */
+ #include "restrict.h"
+ extern struct sym smbl[94];
+ /*
+--- apg.c 2007-03-08 17:32:40.000000000 +0300
++++ apg.c 2007-03-08 17:34:07.000000000 +0300
+@@ -100,6 +100,7 @@
+ #else /* CLISERV */
+ #if defined(APG_USE_CRACKLIB)
+ #define APG_PROGRAMM_OPTIONS "M:E:a:r:b:p:n:m:x:vkt"
++#include <crack.h>
+ #else /* CRACKLIB */
+ #define APG_PROGRAMM_OPTIONS "M:E:a:r:b:p:n:m:x:vt"
+ #endif /* CRACKLIB */
+@@ -709,7 +710,7 @@
+ */
+ char * crypt_passstring (const char *p)
+ {
+- char salt[10];
++ char salt[11];
+ gen_rand_pass (salt, 10, 10, S_SL|S_CL|S_NB);
+ return (crypt(p, salt));
+ }
diff --git a/app-admin/apg/files/apg-glibc-2.4.patch b/app-admin/apg/files/apg-glibc-2.4.patch
new file mode 100644
index 000000000000..be90c6355e66
--- /dev/null
+++ b/app-admin/apg/files/apg-glibc-2.4.patch
@@ -0,0 +1,11 @@
+--- restrict.h.orig 2006-03-26 03:33:50.168661936 +0400
++++ restrict.h 2006-03-26 03:34:10.427582112 +0400
+@@ -33,6 +33,8 @@
+ #ifndef APG_RESTRICT_H
+ #define APG_RESTRICT_H 1
+
++#define uint32_t int
++
+ #if defined(APG_USE_CRACKLIB)
+ #include <packer.h>
+ #endif
diff --git a/app-admin/apg/metadata.xml b/app-admin/apg/metadata.xml
new file mode 100644
index 000000000000..6569104ff6e8
--- /dev/null
+++ b/app-admin/apg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>gentoobugsie.20.dsurawicz@spamgourmet.com</email>
+ <name>Dustin Polke</name>
+ <description>Proxy Maintainer. CC him on bugs.</description>
+</maintainer>
+<longdescription>Another Password Generator. Generates random, pronouncable passwords with a variety of algorithms</longdescription>
+</pkgmetadata>