summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/authbind/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/authbind/files')
-rw-r--r--app-admin/authbind/files/authbind-2.1.1-respect-flags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
new file mode 100644
index 000000000000..2a9eb5f6b84c
--- /dev/null
+++ b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index c1eed73..932ea60 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,10 +34,9 @@ INSTALL_PROGRAM ?= install -o root -g root -m 755 -s
+ INSTALL_DIR ?= install -o root -g root -m 755 -d
+ STRIP ?= strip
+
+-OPTIMISE= -O2
+-LDFLAGS= -g
+ LIBS= -ldl -lc
+-CFLAGS= -g $(OPTIMISE) \
++SHARED_LDFLAGS=
++CFLAGS+= \
+ -Wall -Wwrite-strings -Wpointer-arith -Wimplicit \
+ -Wnested-externs -Wmissing-prototypes -Wstrict-prototypes
+ CPPFLAGS= -DMAJOR_VER='"$(MAJOR)"' -DMINOR_VER='"$(MINOR)"' \
+@@ -82,7 +81,7 @@ helper: helper.o
+ helper.o authbind.o: authbind.h
+
+ $(LIBTARGET): libauthbind.o
+- ld -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
++ $(LD) $(SHARED_LDFLAGS) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
+
+ clean distclean:
+ rm -f $(TARGETS) *.o *~ ./#*# *.bak *.new core