summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-14 07:47:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-14 09:08:00 +0100
commit0f10bf68c044ba9dbc7e45cc6634346d04ee4a1f (patch)
treeb09f056b17091d3d625c7874cc20dce408a0c4e6 /app-admin/awscli
parentdev-python/boto3: Bump to 1.20.35 (diff)
downloadgentoo-0f10bf68c044ba9dbc7e45cc6634346d04ee4a1f.tar.gz
gentoo-0f10bf68c044ba9dbc7e45cc6634346d04ee4a1f.tar.bz2
gentoo-0f10bf68c044ba9dbc7e45cc6634346d04ee4a1f.zip
app-admin/awscli: Bump to 1.22.35
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.35.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index cf9eae40cbde..963ab4de3217 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -8,4 +8,5 @@ DIST awscli-1.22.31.tar.gz 2134102 BLAKE2B e1918352146b3176c8fc60cc6338a69b04a28
DIST awscli-1.22.32.tar.gz 2135177 BLAKE2B 1e99a887e3b90c8fa81547677b4827f50afdad26136a02f225c66702f2f705ee140616cb3ebf407fc4c9bfd242df5cdefe35cf582c565ce1715fde229246173d SHA512 2df81763fbd2314fffe392b35e61f55451063d440a9aa8a62e36977faa49b808d2c0db9bed71c1d73696e53797d8f8f689942e9dd4636a4b6aec3e8f1f16297c
DIST awscli-1.22.33.tar.gz 2146397 BLAKE2B d78f92b077141d7204b2e3c7b2eda589e4430f633c469eefa10f59e2b801d67fc833dcffd55efed379136ea050dfe03f72ef3061e1e3e98a372e61d44f0879cd SHA512 a3474eace16aa90017d985d6f9fc4d927ed27e727bb2e4bbfeda48f0be7d63c9d3648e95904252739a2a94a5d5822c855e2b6b840dad3b6c88da273ec92c9bb7
DIST awscli-1.22.34.tar.gz 2146588 BLAKE2B 794fc2b579126e9c37eaca6aeb8f750cf91769e05ef7222b579e286ef6248d05d49e372abb5af63e1827f804127bfbd78cfe767b715a7f907e26e9c0af6f08a2 SHA512 5fc5f4f929fb64b494422db794cbd4dd2e8adf3d0a3436bc2368a2e9d036bac42e29beab13ee5f00c46b97bc875dbb3f1a7af684006a9dd96be7fcc61ff282fc
+DIST awscli-1.22.35.tar.gz 2147435 BLAKE2B 24fdb6d273dfeddeb7ef8adb15fad843a25edae0cc6dfd37465c294421de6cda0c0c0d49c931f5c2b28ac337d44c3be63f6fd15e7ce84ed493baa0a5c5aa8cc7 SHA512 64f297981987f8f6ab75c43f645624f1794b411f82885e3784c3dd55da0e0ed98ab6395edea7319cbc2c7a320451a6722bd558431a3acb1b7aaf94c2521b4c2d
DIST awscli-1.22.5.tar.gz 2111679 BLAKE2B 970e472e8de43664d060023fdab9f54ce848c5655d8aa417efeae1b1efb52989fd021817521db9dc9cd64580cabbf0c30f3d0178034bdb1edf41feebbc690f46 SHA512 9177fe9da0fb8e9e28777bbf8f2c3fe089a08851b57a49fecefab43417fff187584638d17394289bf6df3d18d9052fd958bd3fbc8064327120af04a0cbe30494
diff --git a/app-admin/awscli/awscli-1.22.35.ebuild b/app-admin/awscli/awscli-1.22.35.ebuild
new file mode 100644
index 000000000000..5327b8227ea2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.35.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}