summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-10 20:34:47 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-10 20:36:10 +0200
commit1b91d5e09b947031a5166668ed67ba211d658275 (patch)
treeedd2cfc8b9cd7dbf11c8aca6644e60783a528456 /app-admin/awscli
parentdev-python/boto3: add 1.21.16 (diff)
downloadgentoo-1b91d5e09b947031a5166668ed67ba211d658275.tar.gz
gentoo-1b91d5e09b947031a5166668ed67ba211d658275.tar.bz2
gentoo-1b91d5e09b947031a5166668ed67ba211d658275.zip
app-admin/awscli: add 1.22.71
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.71.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index be00be2d15f9..fc8ead8cec68 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -13,3 +13,4 @@ DIST awscli-1.22.61.tar.gz 2166385 BLAKE2B e260968803cf274ec6f260bd45bfed4243f70
DIST awscli-1.22.62.tar.gz 2167585 BLAKE2B 39141893c979b0047a45a9aea210d03340fc8fcade9d092297caba07f487faba6304f755e6ab878079a7b9fa6d49a995d57a06334cabcc06d1d1eaad430af03c SHA512 ef9d826e51aa42582a7efa5b599482411e39e056bbee1896a5c67a12c726ece88db0fb314abe7f3c9a7f361ce45fe8de53304bd1375d7a72b822aed79752f5e4
DIST awscli-1.22.63.tar.gz 2167746 BLAKE2B e72126578c9bac30c6d66bdd178961a7a36a045788d8079e8f0ab4c85d18c29454255a13f089c03ef53bdce0949d168c858d03b59cf5d5326fb3de9925a3f487 SHA512 4d8a6ee8b81445fbb51dbb31e899bebb5610b0a1291654eb9b6555685dcb85528c2b928f587d9ff98507f60d2b199ac71c48f6e204e7eb2ce2ba5d7abdd31ec0
DIST awscli-1.22.70.tar.gz 2177284 BLAKE2B 1ba770ba1b1404d6ff31d95ee198cba41321fe79d618d8b2ab8258da75f9cc56d5af95851dbed837b65e4fdbd82193639da5614551fe2d7f0ebc20df44531615 SHA512 0f246e82cee70b8d16e1fc7e30aae67554f5186eb2a0251295b25eafe23d7b29293059be7ebffbe7a45c665d0bae210699093b86bf7b3e188017018d8329af84
+DIST awscli-1.22.71.tar.gz 2177492 BLAKE2B 2634de77b67aedf1684370b18da614d8092da277d099a25aa9ca054743e851df0e4ace5ff8fd884faebb012ad4cc8f0c94892a6c2bc2e1f284c28663b029198b SHA512 a404177ee0b5012553dfa95734d424f744ecc3b4a800ccf6d7f27a0f3b9a93722e4f53e4aed095306ba575328686ef1768095cd796b11064e0b707fadcd1e90c
diff --git a/app-admin/awscli/awscli-1.22.71.ebuild b/app-admin/awscli/awscli-1.22.71.ebuild
new file mode 100644
index 000000000000..21a285d18863
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.71.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}