summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-16 09:23:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-16 09:35:47 +0300
commit399507e7052af7f1254e10b7fc38f6ce1e701208 (patch)
treeab2e9de4ad30e055f1d51857647b685104213f9e /app-admin/awscli
parentdev-python/boto3: add 1.24.74 (diff)
downloadgentoo-399507e7052af7f1254e10b7fc38f6ce1e701208.tar.gz
gentoo-399507e7052af7f1254e10b7fc38f6ce1e701208.tar.bz2
gentoo-399507e7052af7f1254e10b7fc38f6ce1e701208.zip
app-admin/awscli: add 1.25.75
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.75.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index b8cd1b15e488..3d65d0e7ee79 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -6,3 +6,4 @@ DIST aws-cli-1.25.66.gh.tar.gz 2264111 BLAKE2B 7aaa42d654a873fea44fe64e0805c2407
DIST aws-cli-1.25.67.gh.tar.gz 2264702 BLAKE2B 88bdeab8fe85d17d7aa78ff00125e1c3e1d098093d68b7e7213896d101bff443cb2ed23b8ed9245eb3727b41abd34a8047616eee777f802d52b3a26594e214c5 SHA512 a01b333d36160a43c1f28d01600e1f1d095e4713500bac3b13fc336bf790943251fefb72dc7bc177eaf4265b794658d62ff72ee00abd348c1265d04b58564136
DIST aws-cli-1.25.70.gh.tar.gz 2267239 BLAKE2B e20606c8b3df77698f6ad67eb28a63d8ddb5750782a5ca5a690d36bf5ec5d171aebda115a3c828fbae948037d71e11ead73e163fdaa55e81614ea245a51f54e5 SHA512 7984a56f4e224389822ebb6aa56927cc669630ba8fbebbb59178406ce1dcbb298ef0f83353c02ab37eaf4e0bfcd6b86363712d3f711540993044fa6517b84364
DIST aws-cli-1.25.71.gh.tar.gz 2267936 BLAKE2B a44cc3995335d2556e919879127ebac77c274d6a1f55a390acb85d59d1ee3850826a9d0cc1b7d4e86cb7a5abf9ebac00a1a62aa0d0846a06c04166fa40b18abf SHA512 8c0f235a8f16404ca770ff8c157b52981bd808c25c045e39f7cca6b35d992caa921ac84f82309323b1b742ff783296a1d9ca51cb154704270940ce8a900c09b0
+DIST aws-cli-1.25.75.gh.tar.gz 2270365 BLAKE2B 68cd58d03e0712133104dbb145c6d4bcedf8925e59088d0f2c7ecb7c91beb572a3c8c33f55d95e1a2e0e462648c06cde2460e595942e8adb33c3dcab8ec6a2fc SHA512 c21de74e0ae7380a810d11bad53f0233bc50c8959f047d58c4f4c2cd23231fab34dbba1dac6096790adb28b1ca99e22e70019bcda32738df6e984b2bb46abaa8
diff --git a/app-admin/awscli/awscli-1.25.75.ebuild b/app-admin/awscli/awscli-1.25.75.ebuild
new file mode 100644
index 000000000000..3d5bba5c1200
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.75.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).(z-1)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 1 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}