summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-13 08:31:33 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-13 10:37:35 +0100
commit3ef7c4c41fd41b45e7d6ae188db2e11ff9f01d02 (patch)
tree4c578f9fda5ddad1b26e892e83a38593f4358ec6 /app-admin/awscli
parentdev-python/boto3: Bump to 1.20.5 (diff)
downloadgentoo-3ef7c4c41fd41b45e7d6ae188db2e11ff9f01d02.tar.gz
gentoo-3ef7c4c41fd41b45e7d6ae188db2e11ff9f01d02.tar.bz2
gentoo-3ef7c4c41fd41b45e7d6ae188db2e11ff9f01d02.zip
app-admin/awscli: Bump to 1.22.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 48beedba5ad3..9159f9b9ec99 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -7,3 +7,4 @@ DIST awscli-1.22.1.tar.gz 2109309 BLAKE2B 24be9fca3f767745eb2bd8dd77389410a95e58
DIST awscli-1.22.2.tar.gz 2109538 BLAKE2B 09ba6020093a80f1505bf945f0e0946cc37368a9ef1425e1ff20cfe3b19d9cb346f52f22513c58e8820a1454dd296474efaeef6349060819bb29dce972216549 SHA512 64a32f6ae4961f20c52801bcc654fbeb2a84e2bcf582e701ab266ffd61a67b1122a2dcb469ae43c363b87b8b79b59c78738adef7c4677d19c5a7bb4dcb11764b
DIST awscli-1.22.3.tar.gz 2109828 BLAKE2B 48424e51dc05a3a23be5b8e0d71b2a9cc946e740862553e52272213ca30c0b2a863b160bd6301b6dad647369c0ee9de5f99cb6cd882000ee32cc7d89401efe2a SHA512 34ca06dc9261580937e752db42374ce104f79dfa982a553e3c11b196f6d59036ae674ff28e7176e26fe7489685e10b45c5fe4dbb0ed806e898d6e2e300bde5ab
DIST awscli-1.22.4.tar.gz 2110097 BLAKE2B 501c73e6f251081267977920f9844aeb5ebad342414eb9136dc5e873695ceef6886945c90ac7db4e4f70983c73a49e05af13329ee6a1a8a309b631ea7867c577 SHA512 0fb9fe0d43ab0faab3ee6d527d872790a603c208030113a2fe3346fc476dc97198cbd4866e89f29e690756a267f956ba82043c160705e24a4305bc4efa2afacf
+DIST awscli-1.22.5.tar.gz 2111679 BLAKE2B 970e472e8de43664d060023fdab9f54ce848c5655d8aa417efeae1b1efb52989fd021817521db9dc9cd64580cabbf0c30f3d0178034bdb1edf41feebbc690f46 SHA512 9177fe9da0fb8e9e28777bbf8f2c3fe089a08851b57a49fecefab43417fff187584638d17394289bf6df3d18d9052fd958bd3fbc8064327120af04a0cbe30494
diff --git a/app-admin/awscli/awscli-1.22.5.ebuild b/app-admin/awscli/awscli-1.22.5.ebuild
new file mode 100644
index 000000000000..d4b09dbaa2ec
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}