summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 19:43:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:25:59 +0200
commit44614e808c549039369c9da10bc84e26a1d4ded7 (patch)
treed64522bf43eb6ae825b73a020eb2d27fe870258a /app-admin/awscli
parentdev-python/cfn-lint: add 0.58.3 (diff)
downloadgentoo-44614e808c549039369c9da10bc84e26a1d4ded7.tar.gz
gentoo-44614e808c549039369c9da10bc84e26a1d4ded7.tar.bz2
gentoo-44614e808c549039369c9da10bc84e26a1d4ded7.zip
app-admin/awscli: add 1.22.70
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.22.70.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index fbcd7d215628..be00be2d15f9 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -12,3 +12,4 @@ DIST awscli-1.22.60.tar.gz 2165762 BLAKE2B 217c5e889284071eb057b9f345baab711df40
DIST awscli-1.22.61.tar.gz 2166385 BLAKE2B e260968803cf274ec6f260bd45bfed4243f70632b7888464c46c199cf9cda746c7e31e3d11fd542abbffdbf0e614a6089cc3cee24f315d3da4e0d68153613186 SHA512 48866b572fd071166e1e5e189bbde7e797a547fbb50ea665a619fc074d6861d56e8b6016a7efbe957df02969e3f998337409979b67551f6229b15375011d989c
DIST awscli-1.22.62.tar.gz 2167585 BLAKE2B 39141893c979b0047a45a9aea210d03340fc8fcade9d092297caba07f487faba6304f755e6ab878079a7b9fa6d49a995d57a06334cabcc06d1d1eaad430af03c SHA512 ef9d826e51aa42582a7efa5b599482411e39e056bbee1896a5c67a12c726ece88db0fb314abe7f3c9a7f361ce45fe8de53304bd1375d7a72b822aed79752f5e4
DIST awscli-1.22.63.tar.gz 2167746 BLAKE2B e72126578c9bac30c6d66bdd178961a7a36a045788d8079e8f0ab4c85d18c29454255a13f089c03ef53bdce0949d168c858d03b59cf5d5326fb3de9925a3f487 SHA512 4d8a6ee8b81445fbb51dbb31e899bebb5610b0a1291654eb9b6555685dcb85528c2b928f587d9ff98507f60d2b199ac71c48f6e204e7eb2ce2ba5d7abdd31ec0
+DIST awscli-1.22.70.tar.gz 2177284 BLAKE2B 1ba770ba1b1404d6ff31d95ee198cba41321fe79d618d8b2ab8258da75f9cc56d5af95851dbed837b65e4fdbd82193639da5614551fe2d7f0ebc20df44531615 SHA512 0f246e82cee70b8d16e1fc7e30aae67554f5186eb2a0251295b25eafe23d7b29293059be7ebffbe7a45c665d0bae210699093b86bf7b3e188017018d8329af84
diff --git a/app-admin/awscli/awscli-1.22.70.ebuild b/app-admin/awscli/awscli-1.22.70.ebuild
new file mode 100644
index 000000000000..21a285d18863
--- /dev/null
+++ b/app-admin/awscli/awscli-1.22.70.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# awscli 1.22.55 → botocore 1.24.0
+# so botocore is x.(y+2).(z-55)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(( $(ver_cut 3-) - 55))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}