summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-09 08:24:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-09 09:38:03 +0100
commit603b47ba2d3563f45189f88a4c53996526074c9a (patch)
tree9e55c77f127841c5eee32237a72b130caf05cab0 /app-admin/awscli
parentdev-python/boto3: Bump to 1.26.5 (diff)
downloadgentoo-603b47ba2d3563f45189f88a4c53996526074c9a.tar.gz
gentoo-603b47ba2d3563f45189f88a4c53996526074c9a.tar.bz2
gentoo-603b47ba2d3563f45189f88a4c53996526074c9a.zip
app-admin/awscli: Bump to 1.27.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.5.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 23a6c11269af..a0fe448ea915 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -11,3 +11,4 @@ DIST aws-cli-1.27.1.gh.tar.gz 2294930 BLAKE2B 720981aa974ee3999806fc480f9a20afef
DIST aws-cli-1.27.2.gh.tar.gz 2295292 BLAKE2B 6a2bf1e05b8e72880c8f2337da4fbe6dde6844371bbb441043fbb4fe319a68c7f97034eed7415098063a55da8c655332b757f9e18e2c4de8b63f580fe46da41c SHA512 19e0b420e3283c208b75fe0028d26296bf358d8a40e804b0c413bc1ead26d66f88c9dfbc609931d9f5a677d95d9b701089abf4f1df60f0d0ba3cba5e08ea51ac
DIST aws-cli-1.27.3.gh.tar.gz 2295495 BLAKE2B cd396d324f2a7c81df2488e61cd021819d2498fbd1ff58f7e75d24f523df7d17f463eb4133339f429be4f8b1e3ae4eab20dc0bf45b140c2aaa7a91d576f9274e SHA512 6efeae8478486073aac0ebbf56ea10cf337b06be6b2306ebbbc489600e52fac28f4c95f8b8435f5e3a9a9342da59c9ca164a019d04ec17363ecbba533a53d7d5
DIST aws-cli-1.27.4.gh.tar.gz 2296705 BLAKE2B 604306821f91decf0fb6f88d1115000164f393c8a878b5990ca25a2f8d36972a88832079844656e26f084c729aa0e05014e9ff9ca95d1e820346214f5d1bfde1 SHA512 0753e78e43e3d26fcb906c068e78e23ca3ecfbd4607d1f9d8487922d6a1e6b5598b80b9d2cae6236f6b4724e1667b51132c90b66eec7c427ca35aa6f7b3c5f24
+DIST aws-cli-1.27.5.gh.tar.gz 2298711 BLAKE2B 190b2483cf09d4eff2848cc0933a957ae0f6e8fc88a24bc5a0bc637d6c659427fa4145a5509a6fea731fc0f5e09979d8714bdbb0627c0257db4ceb6bd5e09eb9 SHA512 b147660b72604ed29bff27d76ead2018c3c924339472a6499b4553cbb439d239bef11c6ab24a34303b01407da94e79fb5e3729576492340cf097399a637713c0
diff --git a/app-admin/awscli/awscli-1.27.5.ebuild b/app-admin/awscli/awscli-1.27.5.ebuild
new file mode 100644
index 000000000000..9bcb01ac11e2
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}