summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-30 08:56:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-30 09:34:56 +0200
commita0bfb04c3d2278199781abd7aa5521073e380d18 (patch)
treea247fb1b59d3bbc4c8cad14f4c9a70a4dbb4d306 /app-admin/awscli
parentdev-python/boto3: Bump to 1.22.4 (diff)
downloadgentoo-a0bfb04c3d2278199781abd7aa5521073e380d18.tar.gz
gentoo-a0bfb04c3d2278199781abd7aa5521073e380d18.tar.bz2
gentoo-a0bfb04c3d2278199781abd7aa5521073e380d18.zip
app-admin/awscli: Bump to 1.23.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.23.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 7b2a28767984..1f9adcbe2b9c 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,5 +2,6 @@ DIST aws-cli-1.23.0.gh.tar.gz 2197192 BLAKE2B 414646dc2e4ea5638185ab53e78e8de440
DIST aws-cli-1.23.1.gh.tar.gz 2197883 BLAKE2B 1e43b70319d58e689e2ccad38e0b6177c870888c798966a34837f93c340e39b2ac5d351a38e8bed830312931b5764ea6b390a50da9735864dce61a1666da7899 SHA512 a105f8fcfdd36467cc0f328c70a505458c228f69735b23306042944618fbb508efc061c671f7eb743efd13acbe5e4b6ee96205ff14b7f98685fa3f81b3958f9f
DIST aws-cli-1.23.2.gh.tar.gz 2199816 BLAKE2B 7aef7ea7efb2b37b8d63fd64b2e86129d7588aa1d9b2a34d243cf99564be8dee282c4e48e08e900d0988dfe08eaa8af08cb7e79dee235354efb216db5bcb9996 SHA512 04c6324f02afe187c93827433184fbe0d2b82add88488becdcaedb904ddb10332dc93e0c995ef9467216ac19955318bdd9f128022aaa63245bc361ad2061bdc9
DIST aws-cli-1.23.3.gh.tar.gz 2200496 BLAKE2B 4c264c2e551af9df2f84d405a08f1e386da3da48b1b8c6be285bbcbf8d9cd05429828ccbf52a606f0a8e50d440c307d1b03ebf2cf8ca58460384fda4352cb8e2 SHA512 8aa1a0005a4c8be400d9684a92af412815007c8c6f4f7b74915781e8dbb1182de450db194d41a5fdeab68ee5bf9c49329927284305ac76171719e8a3325a9f48
+DIST aws-cli-1.23.4.gh.tar.gz 2200991 BLAKE2B b70012a8dd83d46a460977063ad11111a7af728ee7e00f87cf5d559ff3e1a4eb1824580bfc5f869d749d0e75e336eb3a025a77f2b637a7306dc39fadba2382a1 SHA512 e949b4bf171e1ad4364ced1fbb7bec89d83077ee2de745dfc661fe1518476e7e07a29e58877adbe65c46398602af374d9af47ae976e7984b1ed2e59a67bd4f03
DIST awscli-1.22.101.tar.gz 2196746 BLAKE2B 590938e722e9dff00bcdb4a266f7063bca4e890f5db5e52b56ed710f5777c6e9de3cfe1423cee9ae2cea74d624bdd665cd8af487aec1ba4e650279c700540545 SHA512 ab99b95c5252c48a7a1d10adb053c56e27139e35bb512ce854e90a433e2d028aed2a88f72e518b0f723dea147919961e7cc7f5d980342206e629f750b0fe77ec
DIST awscli-1.22.97.tar.gz 2193983 BLAKE2B f2e0efbb2332d4c405d5e97ba35426424d932a013114492890018d3419349e23aa3c8301f6c29bd8eaa662145b07ceaa30c22e41aad38012ca307400075600ca SHA512 00426aab19fcdf3241850b09d4d5dd6a1460e3ec9baa37cf203068dc6ca0fddd4fe3de7e4e93e8e6539608351777e00692bb8b9d2c362ceeacc55071cd53f422
diff --git a/app-admin/awscli/awscli-1.23.4.ebuild b/app-admin/awscli/awscli-1.23.4.ebuild
new file mode 100644
index 000000000000..c9a5eb0d75aa
--- /dev/null
+++ b/app-admin/awscli/awscli-1.23.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}